Language support

  • Jhule

    #48608

    Hi…
    why does graphene 2.11 not translate my website. For example: The button “continue reading…” is not translated to german “weiterlesen…” and “Filed under” is also in english.

    A bug? My mistake?

    Jhule

    Admin

    Syahir Hakim

    #48618

    The theme’s language files are maintained and updated by volunteers. In your case, the German language file has not been updated for the latest version of the theme.

    You can help update the translation by following the instructions here:
    http://docs.graphene-theme.com/Translating_the_theme

    Jhule

    #48620

    Thanks for your fast reply.
    I used Poedit and translated “Filed under %2$s” to “Veröffentlicht unter %2$s” to german. I saved the .po and .mo file. Then I uploaded to the server and overwrote the 2 files. I overwrote the Child Page (Child/languages) and the original theme page (graphen/languages). But There is still the text in english.

    Any idea?

    Greetings…

    I used this Code in the function.php file in my child theme folder:
    <?php
    add_action( ‘after_setup_theme’, ‘my_child_theme_setup’ );
    function my_child_theme_setup() {
    load_child_theme_textdomain( ‘graphene2.0’, get_stylesheet_directory() . ‘/languages’ );
    }

    function graphene_get_default_headers(){
    return;
    }

    Admin

    Syahir Hakim

    #48660

    @jhule, can you send me the language files so I can test it?

    Jhule

    #48679

    Yes I will! Thank u! Maybe I am to stupid 🙁 to translate the Files.

    Admin

    Syahir Hakim

    #48691

    Thanks for the files. Looks to be working for me:

    Just to confirm, you have changed your site’s language in “WP Admin > Settings > General” to Deutsch, right?

    kak

    #48701

    I’ve also have this problem. My site is setup to “Norsk bokmål” (Norwegian), everything but “Continue reading” is translated to norwegian.

    I’ve checked the .po for the norwegian translation and it seems to have been translated into “Les mer” in the file. But it still shows “Continue reading”.

    Strange.

    Jhule

    #48702

    Hm…yes I have changed the site’s language in “WP Admin > Settings > General” to Deutsch!

    What do I wrong? I use a child theme with the function.php above.

    Any idea?

    kak

    #48728

    When I’m comparing the .po file from 1.9.4.3 with the new one in 2.1.2 this is missing;

    #: loop.php:121
    msgid “Read the rest of this entry »”
    msgstr “Les resten av dette innlegget »”

    Is this the reason why “Continue reading” is not translated?

    Jhule

    #48735

    SOLUTION FOR ME:
    I found the mistake. In the folder “wp-content/languages/themes” there were the 2 files “graphene-de_DE.mo” and “graphene-de_DE.po”.

    Maybe the files were from graphene version 1?!?

    I took the new original files “de_DE.mo” & “de_DE.po” from the directory “graphene/languages” and called them “graphene-de_DE.mo” & “graphene-de_DE.po” as well and overwrote them in the directory “wp-content/languages/themes”

    Now graphene 2.x is in German!!! The website will be translated and the settings in the backend!

    Maybe, this is the solutation for you “kak”???

    Let me know…

    Greetings Jhule

    kak

    #48738

    Thanks for your input, Jhul!

    But it wasn’t the solution for me, I’m afraid! 🙁

    Admin

    Syahir Hakim

    #48751

    @kak, we’ll update all the language files in the next update to for this particular string.

    kak

    #48755

    Thanks, Syahir! 🙂

    popeye13

    #48787

    Hello,
    are there any news about the translation problem?
    I have the same “continue reading” problem.
    I checked the language files, “continue reading” is translated as “weiterlesen” but the site shows the english version.
    Please help!
    Greetings from germany, JM

    Admin

    Syahir Hakim

    #48793

    There are a few other things we need to include in the update. We’re targeting a release window sometime next week.

Viewing 15 posts - 1 through 15 (of 38 total)

You must be logged in to reply to this topic.