White bar across the page, and problem with pages!

  • Anonymous

    #1949

    Hi Everyone!

    I’m new to all this, but loving everything that I’m learning so far! I just created a child theme, thanks to Josh’s help and all is good so far.

    I’ve come across a few more little issues.

    1. I’ve modified all the colours in the options so that the site has a nice grey/dark tone throughout, but there seems to be a thick white bar that goes across after the post area and before the footer area. I can’t seem to find where this is in the options, or how to get rid of it/change the colour of it to grey!

    2. How do I edit the “Home” page – is it set by default? I can’t seem to find it in my pages section to edit. When I try to add another page called Home, there are 2 “Home” pages and the order of the pages is wrong.

    You can see what I mean in this screenshot: http://www.onesixlimited.com/whitebar_example.jpg

    Thanks in advance 🙂

    Anonymous

    #17961

    Pinkcarrot,

    Here’s your answer to your second question.

    2. Graphene uses a dynamic home page by default. This means that as you create posts, your “home” page will be updated to reflect each new post… which you can control in a variety of ways, making it truly customizable.

    If you prefer a static homepage, graphene makes this possible also. The possibilities are really endless. First, you need to decide if you want a dynamic or a static homepage. Then we can move forward from there.

    What’s the url to your site again… and I can help with the first question.

    Anonymous

    #17962

    Hi Josh!

    Thanks for your quick reply again! Ah right, ok. I guess I’d prefer a static homepage then, just to welcome people to the site. Or perhaps I can have a slider there.

    The URL is http://www.onesixlimited.com I’ve got a placeholder there most of the time as I work on the site so that people can’t really see it, but I’ll take it down for now so you can have a look!

    Also, I followed your video on creating the child theme (so clear and helpful!), and

    I created the functions.php file too (I wasn’t sure if it was necessary or not). Now when I try to log out of wordpress, I get this error :

    Warning: Cannot modify header information – headers already sent by (output started at /home/onesixltd/domains/onesixlimited.com/public_html/wp-content/themes/grahpene-child/functions.php:2) in /home/onesixltd/domains/onesixlimited.com/public_html/wp-login.php on line 353

    Not sure what to do?

    Anonymous

    #17963

    You’re welcome.

    Please post your child functions.php file you created here for me to take a look at.

    I’ll go check on the other thing now.

    Anonymous

    #17964

    This might sound silly, but I haven’t put anything in the functions.php file! I only created it as you did in your video, thinking that I’d need it for something later. I literally just wrote in the P tags like you did, so it’s blank otherwise. I feel like such a beginner haha!

    Anonymous

    #17965

    Top create a static homepage, go ahead and make your homepage (it’s ok to have 2 home links in the nav bar for now) and put a little content in it. Go ahead and create a “Posts” page also… you can adjust this later once you see how it’s used.

    Then go to admin panel -> settings -> reading. At the top, tick the static homepage option. Then select “Home” as your front page, and “Posts” as your posts page.

    You can play around with it from there. And yes, you can include your slider on your static homepage.

    Anonymous

    #17966

    That’s okay. We were all there before!

    So, your functions.php should look like this…

    <?
    ?>

    Make sure there is NO white space above or below the two tags… meaning you can’t arrow down from the closing php tag. If you can arrow down, and your cursor goes on to a new line below it, you need to backspace that white space out. Your cursor should be blinking right after the > sign.

    Anonymous

    #17967

    Ahh!! That’s awesome, thanks! I’ve changed the Home page and I understand what the post page is about too… Will play around with it a bit more!

    For some reason though the pages appear in the wrong order on the site even though in the menu options they’re in the right order.

    I’ve resaved the functions file to make sure there is no white space and uploaded it, seems ok now 🙂

    Anonymous

    #17968

    Oh no wait, the error still comes up when I try to log out of WP..

    Anonymous

    #17969

    Ok, one sec. Here is your fix for the white space. Add this to your child theme style.css file.

    #footer {
    background: url("images/sprite_h.png") repeat-x scroll left -992px #111111;
    }

    That white space is actually being pulled from an image file. They can be edited, but it’s complicated. Rather, the code above just adjusts the area being pulled from the image, and I adjusted it accordingly for your site… so it gives a nice little white separation before the footer 🙂

Viewing 10 posts - 1 through 10 (of 19 total)

You must be logged in to reply to this topic.

Do NOT follow this link or you will be banned from the site!