Site lost formatting after changing to child theme

  • JCIMB

    #9246

    Followed steps for creating child theme – created folder, put style.css in folder (the only uncommented line is the import statement), activated child theme, and now header is back to Graphene header instead of header I uploaded, custom menus gone, blocks on home page are re-arranged.

    I do have custom css under Graphene Options.

    My goal was to create a child theme so I could make mods to footer.php.

    Site is: http://previewsds.com/

    Mod

    Kenneth John Odle

    #43122

    Which version of WordPress are you using? This shouldn’t be an issue in latest versions.

    JCIMB

    #43123

    WordPress 3.9.2

    Just now updated Graphene theme from 1.9.2 to 1.9.3

    Mod

    Kenneth John Odle

    #43124

    That was default behavior with older versions of WordPress; hence my reason for asking. But it shouldn’t do that with 3.9.2.

    Quote:
    I do have custom css under Graphene Options.

    Yes, that should be moved to child theme stylesheet eventually. Graphene makes that easy.

    I don’t see anything anywhere that could cause this. You can try disabling plugins to rule out a plugin issue.

    JCIMB

    #43125

    I just now disabled plugins and no change, so I re-activated them.

    What else can I try?

    JCIMB

    #43126

    I also moved custom css from Graphene Options to child theme stylesheet and it did not help….

    sanuja.com

    #43127

    Go to your CPanel or server side file manager and delete the Child Theme from the WP install. This will (should) automatically take the site back to the default Theme.

    JCIMB

    #43128

    I need to get the CHild Theme to work though, because I want to edit footer.php and don’t want it overwritten.

    JCIMB

    #43129

    Ken – are you able to look at how the css files are being loaded to see if that is why the formatting has been lost?

    What else can I try?

    Mod

    Kenneth John Odle

    #43130

    Files are loading in this order:

    <link rel='stylesheet' id='ai1ec_style-css'  href='http://previewsds.com/wp-content/plugins/all-in-one-event-calendar/cache/ea067e5e_ai1ec_parsed_css.css?ver=2.1.2' type='text/css' media='all' />
    <link rel='stylesheet' id='bne-testimonial-styles-css' href='http://previewsds.com/wp-content/plugins/bne-testimonials/assets/css/bne-testimonials.css?ver=1.6.3' type='text/css' media='all' />
    <link rel='stylesheet' id='cff-css' href='http://previewsds.com/wp-content/plugins/custom-facebook-feed-pro/css/cff-style.css?10&ver=3.9.2' type='text/css' media='all' />
    <link rel='stylesheet' id='cff-font-awesome-css' href='//netdna.bootstrapcdn.com/font-awesome/4.0.3/css/font-awesome.min.css?ver=4.0.3' type='text/css' media='all' />
    <link rel='stylesheet' id='graphene-stylesheet-css' href='http://previewsds.com/wp-content/themes/fitkids/style.css?ver=3.9.2' type='text/css' media='screen' />
    <link rel='stylesheet' id='graphene-light-header-css' href='http://previewsds.com/wp-content/themes/graphene/style-light.css?ver=3.9.2' type='text/css' media='screen' />
    <link rel='stylesheet' id='players-1-8-silver-css' href='http://previewsds.com/wp-content/plugins/mp3-jplayer/css/players-1-8-silver.css?ver=3.9.2' type='text/css' media='all' />

    Your child theme is loading third to last.

    You could disable the light style options in Graphene, since you are overriding all of those styles anyway. Not sure if this will fix it, but it will save you some overhead.

Viewing 10 posts - 1 through 10 (of 14 total)

You must be logged in to reply to this topic.