Sidebar widget moved to bottom of page after temporary theme switch

  • holmrk

    #5038

    Hi, after temporarily switching from the Graphene theme to the default 2010 theme and then back again, my sidebar widgets are now all showing at the bottom of the page. Nothing I do in settings (column width adjustment, layout switching, recreating widgets) will make them redisplay at the right hand side. I did absolutely nothing to the site except activate the 2010 theme, look at the site, then activate Graphene again. All settings, layout, etc. remains as before except for this widget problem. Any help to resolve this would be greatly appreciated.

    I just noticed this issue only affects the front page. All other pages have the widget placed correctly.

    Mod

    Kenneth John Odle

    #30395

    You possibly have unclosed <div> in one of your widgets. (If this occurs only on a single page, it is possibly within a post.)

    If that’s not the case, try this:

    https://forum.graphene-theme.com/graphene-support/right-sidebar-moved-to-bottom-of-page#post-23806

    holmrk

    #30396
    Quote:
    You possibly have unclosed <div> in one of your widgets. (If this occurs only on a single page, it is possibly within a post.)

    If that’s not the case, try this:

    https://forum.graphene-theme.com/graphene-support/right-sidebar-moved-to-bottom-of-page#post-23806

    Thanks for your very prompt response!

    Even if I remove all the widgets from the sidebar, I get the “You haven’t placed any widget into this widget area. Go to WP Admin > …..” message box appearing at the bottom of the page rather than at the side. I have also created a brand new simple dummy text widget and this also displays at the bottom. So how can an unclosed <div> in widget text be the culprit? Also, note that I changed NOTHING in the site content, only applied a different theme to a site with correct widget layout and then switched back.

    Also I have already played around with width sliders as suggested in the linked post, to no effect.

    I have also changed layout to widgets on the left side and the widgets will move from the bottom to the left and display as they should for that layout. When I switch back to right side widgets, the problem returns.

    Mod

    Kenneth John Odle

    #30397

    You also have an issue with the footer on that page.

    You haven’t been editing any theme files, by any chance?

    Quote:
    I have also created a brand new simple dummy text widget and this also displays at the bottom.

    Thank you for this. It makes it easier to spot the problem right away and try to get a handle on it.

    Quote:
    So how can an unclosed <div> in widget text be the culprit?

    A <div> is a container. If you close it, then the next one the browser encounters starts a new container. If you don’t close it, the new container goes inside the old one.

    Try temporarily disabling your plugins to see if one those is the culprit. If you need help with that: http://blog.kjodle.net/2012/06/15/disable-your-wordpress-plugins/

    holmrk

    #30398
    Quote:
    You also have an issue with the footer on that page.

    You haven’t been editing any theme files, by any chance?

    I hadn’t noticed that, but yes the footer is now screen width rather than container width on just that page. No I haven’t had any cause to even look at the theme files, let alone edit them.

    I need to stress once again, the site was fine in terms of layout previously and has been for several weeks. I did nothing but swap themes, and after that the front page layout broke. No editing of theme files, no settings changes, nothing.

    Quote:
    Try temporarily disabling your plugins to see if one those is the culprit. If you need help with that: http://blog.kjodle.net/2012/06/15/disable-your-wordpress-plugins/

    Just tried that, disabled all plugins but it had no effect.

    I have also tried deleting all my widgets, not just move them to the inactive area but deleted them. I still get the “You haven’t placed any widget into this widget area…” message at the bottom of the front page.

    I have even tried deactivating Graphene, uninstalling then reinstalling it… no change. The problem persists.

    holmrk

    #30399

    PROBELEM SOLVED! (But I have no idea why!!!!)

    I opened the front page for editing. Made an arbitary text formatting change (removed a carriage return from some text near the top of the page), updated the page and now everything is fine. 🙂

    Thank you for your very prompt responses and suggestions.

    ozant

    #30400

    HI holmrk

    I am havin the same prolem kinly check

    findyourwayinsg.com

    can you tell me in detail what did you do so I can apply for my website as well.

    Anonymous

    #30401

    Try disabling that “Hotel Booking” widget and see what happens.

    ozant

    #30402
    Quote:
    Try disabling that “Hotel Booking” widget and see what happens.

    hi Josh

    I have tried this as well not seems to work =(

    Anonymous

    #30403

    Okay,

    Try changing the status of your latest post from published to draft. Basically, we are removing it from the home page.

    See if that fixes it.

    This one:

    PANTONEMYART 2012: Colour in a state of nature

Viewing 10 posts - 1 through 10 (of 13 total)
  • You must be logged in to reply to this topic.
Do NOT follow this link or you will be banned from the site!