How to change header to a specifc design

  • bigbohan


    I have made changes to the column widths and have increased the width of the page.

    As a result the 960*198 header does not fit in the space required.

    I have amended the space to accommodate a 1025*90 header and have uploaded the file into the media section. I am at a loss as to what to do next. I assume it is adding some customized CSS but I am unsure about how to do this.


    Many thanks


    Kenneth John Odle


    have uploaded the file into the media section

    Go to Appearance >> Header and try uploading it from there.



    Thanks for suggestion. I have tried that but it crops the header to 960*198.


    Kenneth John Odle


    Did you add a filter to your child theme functions file to accomodate the new header size? Take a look at this post:



    Hi Guys,

    I absolutely love the theme. It can surely turn into a commercial theme… I hope I can use it for free as long as possible. 🙂

    I love the new upcoming feature that allows custom widths for the page and sidebars. I can’t wait for that to happen.

    However, I need those tweaks right now and I kind of got stuck. So I bumped into this looking for a solution.

    Here is what I did: modified the css to match my desired layout, this went well.

    The custom width doesn’t match the banner size so the banner doesn’t take all the space in the header.

    I tried the method explained by putting together more resources:

    Installed “Executable PHP widget”, I enabled the graphene_setup action hook and inserted the following code in the designated widget area:


    function graphene_custom_header_width(){

    return 1020;


    function graphene_custom_header_height(){

    return 130;


    add_filter('graphene_header_image_width', 'graphene_custom_header_width');

    add_filter('graphene_header_image_height', 'graphene_custom_header_height');


    The “Custom Header” wizard still wants to crop my images and use the default 960*198 pixels. What am I doing wrong? Can you guys, give me a hand with this?

    The website’s address is at: The Massage Blog

    Thanks for reading this.



    This function should not be put in a widget area.

    Rather, this code should be placed in your child theme’s functions.php file.



    Thanks Josh,

    I’ll give it a try and post back the results.





    K. Let me know if it works (or doesn’t work) for you.



    @Dorian – Please don’t hijack someone’s thread. If you have a question to ask, feel free to start the discussion is a new thread.



    @ Josh – It works, thanks for the help.

    @Prassana – I felt that it would be better for users to read more about the same topic in one place. Having encountered the same problem, I thought that it made sense to share knowledge on the same subject on the same thread. It wasn’t a hijack attempt, sorry about that.

    On another note after fixing the issue with the child theme, which is a great feature, minify plugin doesn’t work anymore for css. The new theme doesn’t get any of the css the inherited one and the child theme css. Any thoughts on that? I disabled minify for css only and that seems to work for now.



Viewing 10 posts - 1 through 10 (of 13 total)

  • 1
  • 2
  • You must be logged in to reply to this topic.
Do NOT follow this link or you will be banned from the site!