Graphene mobile – autofit??

  • APP22

    #6594

    I use the graphene theme & just installed the graphene mobile theme. The blog displays in tiny print on iphones. It autofits on my android & my husbands (motorola & HTC). is there way to to make the site autofit so users on mobile don’t have to zoom in on each page they view?

    Thanks.

    http://amberperrypatterns.com/

    Admin

    Syahir Hakim

    #35003

    Seems like you’ve switched to another mobile plugin for your site. Can’t help you if we can’t see the issue.

    APP22

    #35004

    Perhaps that is the issue…as best I can tell, the graphene mobile theme is the one selected, checked and chosen. I’ve done everything I can think to do to make sure it’s the option chosen. Is there a basic checklist of items I can look at? Standard WP options/plugins that I have to deactivate? I’m frustrated.

    APP22

    #35005

    From my dashboard:

    WP Mobile Detector – Mobile Themes

    Current Mobile Theme

    Current theme preview

    Graphene Mobile 1.2.2 by Syahir Hakim

    A mobile WordPress theme, developed for optimised site display on mobile devices.

    All of this theme’s files are located in /themes/graphene-mobile.

    Tags: black, blue, white, one-column, theme-options, sticky-post, translation-ready, rtl-language-support

    …..

    Also, under Mobile Smart, Graphene mobile is the theme selected.

    APP22

    #35006

    I just tried choosing another mobile theme, activated it, checked on my mobile – still looks the same. Went back to the mobile themes and previewed Graphene Mobile (using my laptop), and it’s GORGEOUS, however, after I activated the Graphene Mobile theme, I still have the theme from before on my mobile. I just can’t seem to get WP to recognize Graphene Mobile (or any other mobile theme apparently) as my active mobile them.

    Admin

    Syahir Hakim

    #35007

    If you have WP Mobile Detector, don’t use Mobile Smart, or vice versa. Use one or the other, but never both. Also, make sure that you don’t activate the mobile theme, as the mobile detector plugin will do this for you when it detects mobile devices. You should only activate your main desktop main, Graphene in this case.

    APP22

    #35008

    I have deactivated Mobile Smart and have Mobile Detector running.

    In Mobile Detector>Mobile Themes, I have the main Graphene theme selected (not Graphene Mobile)

    Under Appearance>Mobile Switcher, I also have the main Graphene theme selected (not Graphene Mobile).

    This changed nothing on the mobile site. I also tried setting both of these settings to Graphene Mobile, also with no change. I also tried selecting the option of what looks like a line (


    ) for the theme in the dropdown in the switcher, no change.

    I also tried all of the above with Mobile Smart while having Mobile Detector deactivated, also with no change.

    Please advise. It seems odd that no matter what changes I make, I can’t seem to get anything to change for the mobile appearance.

    Admin

    Syahir Hakim

    #35009

    OK, let’s try all this once again.

    1. Deactivate all mobile detector plugins.
    2. Make sure Graphene theme is the active theme in WP Admin > Appearance > Themes.
    3. Make sure that Graphene Mobile is installed, but not activated in WP Admin > Appearance > Themes.
    4. Activate Mobile Smart plugin. Go to WP Admin > Settings > Mobile Smart, and set Graphene Mobile as the mobile theme.

    Let me know when you’ve done exactly that and nothing else so that I can take a look.

    APP22

    #35010

    I have just now done everything you listed, in the order you listed.

    You did not mention WordPress Mobile Pack, so I have that deactivated as well. The ONLY mobile plugin active is Mobile Smart.

    WP Admin > Appearance > Themes: Graphene

    WP Admin > Settings > Mobile Smart: Graphene Mobile

    Admin

    Syahir Hakim

    #35011

    It appears that your site is loading one of the Jetpack mobile theme module (specifically, the Minileven mobile theme). Try going into Jetpack options and disable any mobile theme / detection module.

    APP22

    #35012

    Wow! It appears that was the issue. The Jetpack menu stinks!! It did not appear that anything on there was active – until I hovered over “learn more” and then it gave a blurb about what it does and the deactivate button became visible – “deactivate” was hidden until the hover.

    Many thanks!

    Now, with the WP Mobile Pack deactivated, I get a 0% for the W3c mobile validator…should I reactivate that plugin?

    Admin

    Syahir Hakim

    #35013
    Quote:
    Now, with the WP Mobile Pack deactivated, I get a 0% for the W3c mobile validator…should I reactivate that plugin?

    You shouldn’t need to. W3C is giving a 0% score because the mobile theme is not served to its user agent. But you shouldn’t worry about that since it doesn’t really affect your site in any way.

    On the other hand, you really wouldn’t want to activate more than 1 mobile detector plugins at once, as they’ll more likely than not conflict with each other.

    APP22

    #35014

    I’m sorry, the validator now says 21%… and having the WP Mobile Pack active seems to make no difference. mobiReady gives it a “bad” rating. Anything to do to improve these?

    APP22

    #35015
    Quote:
    Now, with the WP Mobile Pack deactivated, I get a 0% for the W3c mobile validator…should I reactivate that plugin?

    You shouldn’t need to. W3C is giving a 0% score because the mobile theme is not served to its user agent. But you shouldn’t worry about that since it doesn’t really affect your site in any way.

    On the other hand, you really wouldn’t want to activate more than 1 mobile detector plugins at once, as they’ll more likely than not conflict with each other.

    Alright. Thank you again! Looks so much nicer & navigation is so much better!

Viewing 14 posts - 1 through 14 (of 14 total)

You must be logged in to reply to this topic.