Generic avatars no longer display in comments after upgrade to 1.6

  • Anonymous

    #23878

    Hmm.. Can you temporarily decrease your container width to 960px and check whether it is causing the problem or not?

    deputy963

    #23879

    Changing the container width back to 960 does not affect the display the of generic comment icons.

    Anonymous

    #23880

    Did you select Blank in Settings –> Discussion –> Default Avatar ??

    Mod

    Kenneth John Odle

    #23881

    we get a ton of spam comments and forum posts

    Use Akismet. It is really effective at blocking spam.

    The grey sliver is not a grey sliver. It is actually the border around your avatars. There is no link to the avatar image at all, nor is there a closing </img> tag.

    The gravatars come from *.gravatar.com. It’s possible that your IP blocking is also blocking importing of the gravatar images.

    Anonymous

    #23882

    The gravatars come from *.gravatar.com. It’s possible that your IP blocking is also blocking importing of the gravatar images.

    Yeah! That might be causing the problem!

    deputy963

    #23883

    I do use Akismet. Commenters are allowed to signup for our newsletters and when we receive spam comments those “junk” addresses are added to the mailing list. This creates several problems, so I’ve added AVH which checks Stop Forum Spam, project honeypot, and others by IP. When a know spam IP accesses the site it is cached and blocked. For those that get by the previous checks they are moved to the spam page (as with akismet) but there is a new option (delete, block, and reportd) which allows be to delete the comment, block the IP, and report it to the above services – AVH works very well. We went from between 50 and 75 spam comments a day to between 1 and 5.

    I just tracked down the issue. The forum plugin I’m using (simple press) had an update over the weekend, which added the ability to replace WP avatars with simple press avatars. I wasn’t aware of this and must have missed it in the changelog, or it’s been there all along and just started working in the last update.

    The WP settings were correct and the SP settings have been changed to correct the problem.

    I apologize for the confusion and thank you both (Prasanna and Ken) for taking the time to offer your advice and attempting to track down the issue!

Viewing 6 posts - 11 through 16 (of 16 total)
  • You must be logged in to reply to this topic.
Do NOT follow this link or you will be banned from the site!