Return to Bug Report

Disable video in post listing not working with Stacks

Home Forums Franz Josef Bug Report Disable video in post listing not working with Stacks

Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
    Posts
  • #10518
    Gendji
    Participant

    The option Disable video in post listing doesn’t work together with FJ Stack: Posts.

    It still shows the video as the “Featured Image”.

    With normal post lists based on category for example, it works as expected, featured image is show, not the video.

    I tested it by using a featured image and an image in the post itself. Either way, the video is shown.

    FJ Stack: Posts example Here

    Normal listing based on Category: Here

    It’s the last message “Recordaantal (40.006) lichtjes voor herdenking Q-koortsslachtoffers” (use load more)

    Don’t worry there aren’t that many messages there yet đŸ™‚

    #46330
    Gendji
    Participant

    I have narrowed down the problem to the auto embedding of WordPress.

    Meaning that if you put a video link in a post right away, the video will show as the featured image, regardless of any image in the post or if you use a featured image.

    If i use <iframe></iframe> to embed a video, this doesn’t happen.

    On a side note. changing a post from WP embed to iframe doesn’t change the featured image. Page builder uses some sort of cache?, which still shows the video as featured image after changing the post. Deleting the post and making it again seems to be the only thing that works.

    Apparently some themes using Page Builder, have an option to clear that cache but i haven’t found that option in FJ.

    #46331
    Venutius
    Member

    Thanks for the tip, it did not seem to work on my pages, no matter what I tried the iframe would not display the video

    #46332
    Gendji
    Participant

    Have you tried using <iframe></iframe> in the text editor? Doesn’t work with the visual editor.

    #46333
    Venutius
    Member

    Yep I’ve tried that, it’s still not displaying, I jusr get a blank box on the post

    #46334
    Gendji
    Participant

    Do you have a link to the video so i can test it myself?

    #46335
    Venutius
    Member
    #46336
    Gendji
    Participant

    Using <iframe width="560" height="315" src="https://www.youtube.com/embed/NBl4mLID9dQ" frameborder="0" allowfullscreen></iframe>

    the video displays correctly used in a post.

    #46337
    Venutius
    Member

    Yes it does! Thanks!

    #46338
    Venutius
    Member

    The only trouble is the videos are still showing instead of the featured image.

    #46339
    Gendji
    Participant

    I my case i deleted the posts and made them again using iframe. It seems that Stacks (Page Builder) uses some kind of cached version of posts to show the featured images in rows of posts.

    If that doesn’t work, try deleting the posts, remake them using iframe but change the titles slightly.

    You can change the post dates manually if you want the keep the order in which they were posted originally.

    #46340
    Syahir Hakim
    Keymaster

    Hi Gendji,

    Have you tried the option to disable videos in posts listing? It’s in WP Admin > Appearance > Customize > Franz Josef: Display > Posts > Disable video in posts listing.

    #46341
    Venutius
    Member

    Yes that option is checked.

    #46342
    Gendji
    Participant
    Quote:
    Hi Gendji,

    Have you tried the option to disable videos in posts listing? It’s in WP Admin > Appearance > Customize > Franz Josef: Display > Posts > Disable video in posts listing.

    Yes i have, it is disabled.

Viewing 14 posts - 1 through 14 (of 14 total)

You must be logged in to reply to this topic.