Return to Support

Wrong width for widget header and menu

Home Forums Graphene WordPress theme Support Wrong width for widget header and menu

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #8816
    Josif
    Member

    Dear users of graphene,

    I have been experiencing problems with my Plugins and Menus. The heading of my plugins is too short and so are the menus. You can check it out here: “http://www.4xbroker.cz“.

    Does anyone has the same problems?

    The problems started when I instaled “customer area” plugin which uses its own stylesheet. Unfortunately this plugin is essential for me so I cannot remove it. Is there any way I could solve this?

    The same trouble is causing the “WordPress Twitter Bootstrap CSS”.

    Thank you very much!

    Josef

    #42233
    Luko
    Member

    What do you mean by “headings of my plugins”? If you mean that transparent gap in sub-menus, that is caused by this custom css:

    #header-menu ul li a, #secondary-menu ul li a {
    width: 160px;
    }

    #42234
    Josif
    Member

    Luko, thanks for answering!

    Actually you cannot see that problem now because I managed to remove it by modifying the padding and setting up the width to 112%.

    But the problem with submenus is like its set to stone.

    First I could not find the exact code as you showed. All I could find is this:

    Quote:

    /* Sub level header menu, default state */

    #header-menu ul li a{

    color: #000;

    padding: 10px;

    width: 180px;

    }

    But changing these setting to what you proposed did not help. Not even pasting the code you showed.

    Is it possible that there is something else that ist overwriting this code or am I just looking in the wrong place?

    Thanks a lot,

    Josef

    #42235
    Josif
    Member

    Hooray! margin-left: 20 px helped. Now all I have to do is move the text inside 20 px to the let and its solved. But how could this happend? How can there be conflict with other plugins?

    #42236
    Luko
    Member

    That code that I mentioned before is reason for that gap. Remove that margin-left and simply add !important to 180px width. Like this:

    #header-menu ul li a {
    width: 180px !important;
    }

    You should consider using child-theme.

    #42237
    Josif
    Member

    Thanks a lot Luko, you are absolutely right, I going to use it..

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.