WooCommerce Pushing Sidebar to Bottom

  • CPClemens

    #9508

    Hey Guys…

    Working on setting up a WooCommerce Page on my site. Installing the shortcode in to the page displays the shop correctly, but one of the sidebars with widgets gets pushed down to the bottom. I don’t really need the widgets on the shop page, so I went in to Page attributes and made it a single column.

    The problem I’m having is that making it a single column Page doesn’t actually remove the sidebars. What piece am I missing?

    Thanks in advance…

    Mod

    Kenneth John Odle

    #43790

    Usually, this kind of behavior is the result of an unclosed </div> in a text widget. So the first step would be to make sure that you don’t have any of those in the page.

    Quote:
    The problem I’m having is that making it a single column Page doesn’t actually remove the sidebars.

    Link to page in question?

    CPClemens

    #43791

    Thanks Kenneth.

    As a bit of a newb, I’m not exactly sure where to start looking for the <div> you mentioned, but I’ll look in to it.

    The Page I’m working on with WooCommerce isn’t public cause I don’t like how it looks, but the entire site is the same layout.

    http://www.ExploringUpstate.com

    Mod

    Kenneth John Odle

    #43792
    Quote:
    The Page I’m working on with WooCommerce isn’t public cause I don’t like how it looks

    Sometimes you gotta live with the ugly in order to get it fixed.

    CPClemens

    #43793

    Fair enough…. I’ll leave it as public for the rest of the night so you can check it out…

    http://wp.me/P50DQZ-do

    Mod

    Kenneth John Odle

    #43794

    When I look at your page’s <body> tag, I see this:

    <body class="archive post-type-archive post-type-archive-product
    custom-background woocommerce woocommerce-page
    three_col_left three-columns">

    but I should see something like this:

    <body class="page page-id-137 page-template page-template-template-onecolumn-php
    logged-in admin-bar no-customize-support one_column">

    Your page is actually an archive page. I’m not sure how you did that, or if that is something that WooCommerce sets up for you. I’m not familiar with WooCommerce.

    CPClemens

    #43795

    Thanks. I’m sure it’s something that I did cause I don’t know what I’m doing. I’ve been going through all the settings everywhere and have no idea what I did wrong.

    Thanks for the assistance, I’ll keep plugging away.

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.