Widgets: How can I get them to show up on each page?

  • resourcefulblogger

    #4315

    Just started my first WordPress and love the graphene theme. I’ve run into a problem with how to get my widgets to show up on each page. I tried to use a widget context plugin but can’t get it to work. Any help appreciated.

    http://www.resourcefulblogger.com

    Kim Litchford

    Also, need help with setting up email opt in form and an email button on top on header bar.

    Josh

    #27869

    Regarding the widgets, simply visit your admin panel -> appearance -> widgets. Then, you can select from a variety of default wordpress widgets to add to your sidebars.

    You will need to click and drag a widget, and drop it into one of the sidebar locations. You can then usually further customize the widget once it has been placed in a placeholder.

    Email opt in forms are probably available via a plugin. A quick search on the plugin repository gave this plugin:

    http://wordpress.org/extend/plugins/newsletter-manager/

    But you can also search “email opt in” and get a list of similar plugins:

    http://wordpress.org/extend/plugins/search.php?q=email+opt+in

    resourcefulblogger

    #27870

    Thanks so much. I will try it out now. Kim

    resourcefulblogger

    #27871

    I can not drag or drop widgets. I can click the add button to add to sidebar. When I do that I don’t know what to do next to get it on all pages. I can see my options and have tried checking and unchecking everything and tried to use the target url but didn’t work. I don’t exactly know what to type in for target url. So confused. Thanks

    resourcefulblogger

    #27872

    I’ve only been using wordpress for 1 week. 🙂

    resourcefulblogger

    #27873

    On my sidebar it gives me the option where to post it, example, Sidebar, Footer etc… But whatever I put in sidebar only is showing up on home page.

    Josh

    #27874

    Regarding the drag and drop, click on the “screen options” in the top-right of your page when you’re on the wordpress widgets page. There is an option to “enable/disable accessibility mode”. Click it to disable.

    Regarding the widgets only on your home page. This is because of how you have your blog setup.

    1. Scrap the home page you currently have (just change it’s status to draft, we might need the info later).

    2. Create a new home page, but don’t add any content (unless you want to).

    3. Now, go to appearance -> menus. You want to add a new custom menu.

    4. Drag any page/post/tag/category you would like to display in the nav menu across the top of your site, over to the newly created custom menu.

    Lastly, you can position your posts/pages/tags/categories in the order you would like for the nav menu, and also you can “indent” them to create child pages (dropdown menu items).

    resourcefulblogger

    #27875

    I can not find where my Home page is listed. I went to pages and the Home page is not listed. I wander if I deleted it. Not sure. Can you tell me where I should be able to find my Home page?

    BTW, I don’t have any Menus set up at all because I wasn’t sure how to use them. Don’t know if this is important or not.

    I would be willing to let you sign in to my account if this will help. Thanks

    resourcefulblogger

    #27876

    I clicked on all pages and the Home page is not listed.

    resourcefulblogger

    #27877

    Just checked out your website. Love it! Especially your tag line. “The Happiest People Don’t Have it All… They Just Make The Best of What They’ve Got” Fits me perfectly!

Viewing 10 posts - 1 through 10 (of 17 total)

You must be logged in to reply to this topic.

Do NOT follow this link or you will be banned from the site!