Why a strange image when pasting to Facebook?

  • dnourie

    #3754

    Hi,

    When I first installed Graphene, posting article to Facebook, etc worked great. But now, suddenly, when I post an article from our site, this weird image comes with it:

    http://external.ak.fbcdn.net/safe_image.php?d=AQBU__FABHCB8JOI&url=http%3A%2F%2Fwww.gravatar.com%2Favatar%2Fcdccda64a6808af2bd76035aa3e380cc%3Fdefault%3D%26size%3D110.jpg

    Any idea why this is happening, and how come the first image in the article isn’t being used? So you know, the graphics for the article is uploaded in wp, and shows fine on all pages of the site. This article for instance is appearing with that weird image:

    http://www.secularbuddhistassociation.com/2012/03/07/the-first-watch-of-the-night/

    It should be showing the little buddha image, as in the article. Thank you! Dana

    Mod

    Kenneth John Odle

    #25800

    That image is not showing up here. Apparently your host doesn’t allow hotlinking to specific image files.

    About the FB image: it really is up to Facebook to decide which image they are going to grab. I don’t know how you are posting an article to Facebook, but there is (for me, at least), an option to scroll through various images to select which one will appear (or no image).

    dnourie

    #25801

    Ah, ok. I had suspect that. Earlier I had put code in my .htaccess file to prevent hotlinking. Thinking that might be the cause, I removed it. Now when I post articles, a pix of me shows up. LOL. FB, I notice does some weird stuff with that now and then. Ok, I’ll hope FB resolves it’s weirdness.

    Thank you!

    Mod

    Kenneth John Odle

    #25802

    Ok, I’ll hope FB resolves it’s weirdness.

    That’s asking a lot! 😉

    Seriously, though, I’m not sure how FB grabs on to images. It was my belief (imagination?) that they capture a copy and then cache it, so if your hotlinking prevention goodness in your htaccess file prevents them from getting it, then they might just grab your gravatar, which is hosted at gravatar.com. You might want to add an exclusion for Facebook in your htaccess file and see if that takes care of the problem:

    http://samanathon.com/how-to-create-an-htaccess-file-to-prevent-hotlinking/

    (See the bit about “Google Cache/Image Search/Reader”)

    dnourie

    #25803

    Thank you, Kenneth! I’ll check that out.

    Anonymous

    #25804

    Search around the forum. Syahir has answered this question.

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.

Do NOT follow this link or you will be banned from the site!