Uncaught TypeError: $(…).tooltip is not a function

  • getsby

    #51076

    Hello,
    not sure if I am supposed to post this as a bug here in the Graphene theme forum, but since I’m having this issue with Graphene theme (and not with another theme) will do it anyway.
    The problem is actually with a plugin Simple Share Buttons Adder. After its installation, when trying to set it up it bombs with js error:

    Uncaught TypeError: $(...).tooltip is not a function
        at Object.init (admin.js?ver=5.2.2:38)
        at Object.<anonymous> (admin.js?ver=5.2.2:26)
        at i (load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,utils,underscore,wp-util,moxiejs,plupload&ver=5.2.2:2)
        at Object.fireWith [as resolveWith] (load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,utils,underscore,wp-util,moxiejs,plupload&ver=5.2.2:2)
        at Function.ready (load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,utils,underscore,wp-util,moxiejs,plupload&ver=5.2.2:2)
        at HTMLDocument.J (load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,utils,underscore,wp-util,moxiejs,plupload&ver=5.2.2:2)

    The code in question is:
    $( '[data-toggle="tooltip"]' ).tooltip();

    Once again, this error is not present if I change the theme of the site to Twenty Nineteen, or other theme for that matter.

    Best regards,
    Nikolay

Viewing 1 post (of 1 total)

You must be logged in to reply to this topic.

Do NOT follow this link or you will be banned from the site!