Unable to Click “Some” Links

  • flpetersen

    #51514

    Things were working fine until this AM when I started to notice that various plugin links (settings, etc.) were simply unclickable, or when clicked, did nothing.

    I can click the links, they still appear as a link, but nothing ever happens, no dropdown menu, no new page loads. its not all links however, for example:

    These WP links for the plugin work:

    But these links don’t work:

    These buttons work:

    But once the new page loads, this dropdown does not:

    I started to troubleshoot the first plugin (wpDataTables), was my license still valid, etc. All good.
    I then disabled all plugins beside the one in question and it was still not working.
    I deactivated, reactivated the plugin, I swapped browsers, still not working.

    Finally I fell back to the default 2020 theme and violla, it all works again.

    I am stumped, and frustrated. The site sadly is on an internal network, so I cannot offer access.

    Any ideas?

    Admin

    Syahir Hakim

    #51520

    This sounds like a script conflict. On your browser while accessing any of those pages that don’t work correctly, press F12 to bring up the developer console. Then click on the “Console” tab, and see if there’s any error listed there.

    flpetersen

    #51541

    Sorry, long weekend in the states.

    If I am using the default 2020 theme and wpDataTables, the console shows no errors and the page works: https://i.imgur.com/MEkHfBf.png

    If I am using Graphene theme and wpDataTables, the console shows the following error: https://i.imgur.com/zqXmMvq.png

    Admin

    Syahir Hakim

    #51543

    Thank you for the screenshots. We’ve determined the cause and will include the fix in the next theme update.

    To apply the fix in the mean time, add the following code to line 6 of the file graphene/inc/compat.php:

    if ( is_admin() ) return;
    

Viewing 4 posts - 1 through 4 (of 4 total)

  • You must be logged in to reply to this topic.
Do NOT follow this link or you will be banned from the site!