Return to Support

TinyMCE 100% bug : Not acceptable

Home Forums Graphene WordPress theme Support TinyMCE 100% bug : Not acceptable

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #10487
    Sylaxo
    Member

    I use the latest TinyMCE Advanced version. I discovered the bug in an older version a few months ago.

    When the percent symbol % is present on a page or article it is impossible to save the document.

    A message is displayed : 406 Not Acceptable.

    #46232

    That is…weird.

    Try a different browser to rule out something funky with your browser. (I seriously doubt this is it, but this is quick and easy to check.)

    Then verify that it really is theme related by temporarily switching to the default WordPress theme (TwentySixteen) and trying again. If the problem goes away, it is probably a theme issue.

    If the problem doesn’t go away, rule out a plugin conflict by temporarily disabling all of your plugins except for TinyMCE Advanced. If the problem goes away, it’s due to a plugin conflict—you have two (or more) plugins that aren’t playing nicely with one another.

    If not, verify that it is TinyMCE Advanced + Graphene by turning your plugins back on and then disabling TinyMCE. If the problem goes away, it’s a plugin problem, and you’ll need to post in the plugin’s support forum on wordpress.org.

    Does this happen on both pages and posts? Does the percent symbol have to be in the title, or can it be anywhere on the page?

    Are you referring to this plugin:?

    https://wordpress.org/plugins/tinymce-advanced/

    #46233
    Sylaxo
    Member

    I did carefully everything you said. I used Firefox and Chrome.

    The problem was the same with the twentysixteen theme, it was the same when all plugins were disabled, it was still there after I turned the plugins back on and disabled Tinymce and tried again.

    The version of TinyMCE Advanced is 4.4.1

    The problem appears whatever the location of the % symbol in a Post or a Page : title and text.

    As I don’t work with statistics it’s not a crucial problem…

    Thank you for your help. I suppose somebody somewhere should be informed, even if I represent only 0.0…01% WordPress users!

    #46234

    If that’s the correct plugin I linked to, then you should open a ticket here:

    https://wordpress.org/support/plugin/tinymce-advanced

    But wait! Did you say this happened even with this plugin turned off? If that’s the case, then there’s probably something wrong with your WordPress install. Did I read that correctly?

    #46235
    Sylaxo
    Member
    Quote:
    If that’s the correct plugin I linked to, then you should open a ticket here:

    https://wordpress.org/support/plugin/tinymce-advanced

    But wait! Did you say this happened even with this plugin turned off? If that’s the case, then there’s probably something wrong with your WordPress install. Did I read that correctly?

    That’s correct.

    And I’ve just tested again. I disabled TinyMCE Advanced and created a new page using the text editor which displays a one-line tool menu. I wrote a title and typed % in the text area.

    On saving the page it closes and a new page is displayed with the “406 Not Acceptable” message. When coming back to the editor page the title and the text have been deleted.

    So it seems TinyMCE Advanced is not the cause

    Wordpress has recently been updated to the 4.6.1–fr_FR version, but the problem existed before. I don’t know if it can be linked to the coding of accented characters in the French language but I found no mention of it in French-speaking WordPress forums.

    #46236

    In that case, it’s most likely a WordPress or server issue. You can read through similar issues in the wordpres.org support forum here:

    https://wordpress.org/search/%22406+Not+Acceptable%22

    and if you can’t find anything that helps, try creating a new post here:

    https://wordpress.org/support/forum/how-to-and-troubleshooting/

    Do be sure to mention that you’ve searched the forum and that you’ve tried the things you’ve mentioned above. Feel free to link to this forum post as well, so that people know you’ve researched this on your own.

    Let us know if you find out anything useful.

    #46237
    Sylaxo
    Member

    I had already searched French-speaking forums and found that the 406 message was often related to mod_security, so I changed .htaccess according to suggestions. With no effect.

    But what I noticed in many posts in the forum you recommended,

    https://wordpress.org/search/%22406+Not+Acceptable%22

    is that contact with the host server support about this problem had always proved successful.

    So it is what I am going to do.

    I’ll keep you informed. Thanks a lot.

    #46238
    Sylaxo
    Member

    It took a little time before I could get in touch with the host server support. They asked me for my IP address and further details about the problem. Today’s reply informed me they had disabled mod_security and everything should be OK now.

    But it not!

    Still the same…

    #46239
    Sylaxo
    Member

    The second intervention has been the right one. I am 100% satisfied…

    Thank you Kenneth for your precise and patient help.

    #46240

    You’re welcome! As this isn’t a bug with Graphene, I’m going to move this thread to support and mark it resolved.

    Cheers!

    #46241
    Sylaxo
    Member
Viewing 11 posts - 1 through 11 (of 11 total)

You must be logged in to reply to this topic.