Tiny MCE help

  • Anonymous

    #5706

    In HTML mode, the default behavior of the Tiny MCE editor after hitting a return is single spacing;

    in Visual mode, it is double spacing. Is there a way to make it single spacing in both modes?

    Thank you!

    Martin

    ronangelo

    #32533

    The editor doesn’t do double spaces.

    there’s just a difference between the line-height and <p> margins of WYSIWYG and HTML mode.

    You can manually change that in the editors css.

    Anonymous

    #32534

    Thanks, but I am confused. If I cut and paste text that I typed in Visual mode into say textwrangler, it shows two returns, whereas, if I do the same with text typed in HTML mode, it shows just one. Also, if I use shift-return in Visual mode, it gives me single spacing (one return).

    I would just like to change the default behavior to be the one like shift-return.

    Thanka again!

    Marin

    p.s. Can I do this with a custom CSS in the graphene options?

    ronangelo

    #32535

    I guess you’re right.

    If its a behavior, then I think css can’t change it.

    I also have no idea how to.

    Anonymous

    #32536

    Press Shift + Enter to get single line space in Visual Editor.

    Anonymous

    #32537

    Thanks Prasanna, I know that–I want to make single spacing the default. There is also an issue that when people paste in a text typed in MS Word, in Visual mode it becomes double spaced. The Shift trick doesn’t solve that. Since the board is a poetry board, that is an important issue. Poking around on the WP codex, it does seem possible to turn off the double spacing–but I’m not sure how.

    Any help would be appreciated.

    Thanks,

    Martin

    Mod

    Kenneth John Odle

    #32538
    Quote:
    Poking around on the WP codex, it does seem possible to turn off the double spacing

    I would suggest posting this on the WordPress forums, with links to the threads you were looking at there. Your chances of getting the answer you are looking for is higher over there.

    Anonymous

    #32539

    Thanks, I was hoping that Josh might have some hints. Also, I was hoping that I could do it with Custom CSS; I actually

    tried something that I found:

    .tinymce-content p {
    padding: 0;
    margin: 2px 0;
    }

    but it didn’t help and broke the editor and was a hassle to fix.

    I’ll give it a try.

    Martin

    Mod

    Kenneth John Odle

    #32540
    Quote:
    I was hoping that I could do it with Custom CSS

    Yes, but there is a difference between what you type in code (such as a line feed or cursor return) and what you get in outputted html. Paragraphs are block level elements, and usually have a bit of top margin to distinguish them from each other.

    Josh has a forum you could also post this on. It’s at http://www.forum.joshlobe.com/

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.

Do NOT follow this link or you will be banned from the site!