Return to Bug report

The new graphene shortcodes plugin is spoiling the layout of my home page!

Home Forums Graphene WordPress theme Bug report The new graphene shortcodes plugin is spoiling the layout of my home page!

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #9652
    flying_roger
    Member

    I have downloaded and installed the “graphene shortcodes” plugin without problem on my wordpress3 web site (rycw.be) and the features seemed to work.

    However, this plugin spoiled my home page with unwanted side effects on the text layout (even outside the text using shortcodes).

    Reversely, applying simple modifications elsewhere had side effects on the text using shortcodes.

    I could not rely on a stable behaviour; it looks like the wordpress3 editor is competing with the shortcodes plugin.

    After spending some time trying to fix this, I decided to disable the shortcodes plugin and to look for another text enhancing solution.

    I sincerely wish I could go back to version 1.9.3 as I found theses shortcodes interesting.

    Maybe the plugin will be improved in the future, but it obviously requires further debugging.

    #44232

    I don’t know how this is possible, since all the shortcode plugin does is return a function which was originally included with the theme. (I.e., the function has moved from the theme to the plugin.) Nothing else has changed.

    Quote:
    it looks like the wordpress3 editor is competing with the shortcodes plugin.

    You should update WordPress to 4.1. WordPress 4is the version that Graphene 1.9.4 and the shortcode plugin was designed to work with.

    Quote:
    However, this plugin spoiled my home page with unwanted side effects on the text layout (even outside the text using shortcodes).

    What do you mean by “Unwanted side effects”? This is too general for us to provide any sort of solution.

    Did you try the usual debugging techniques, such as temporarily disabling all other plugins except this one to see if the problem persists? Making sure that all of your WordPress core, theme files, and plugins have been updated to the latest version? Making sure you don’t have errors in any code (php, css, or html) that you have written?

    #44233
    flying_roger
    Member

    Thank you for your fast reply.

    Sorry for the confusion, this is actually wordpress 4.1 (the hosting folder is named rycw.be/wordpress3 ;-).

    By “unwanted side effects”, I meant that the aspect of the page, especially bulleted items and spacing between paragraphs changed when I activated the plugin. I did the deactivation/activation test twice this morning, every time with the same result.

    However, I have now repeated the test to take screenshots and had the surprise to no longer observer changes.

    What I did between the test this morning and now is to remove all shortcodes, but one.

    Instead, I used table cells with background colour.

    Maybe during this exercise, I solved a possible html tag error, thereby allowing the plugin output to be properly interpreted.

    I will give it another chance and keep the plugin enabled, keeping you posted in case the problem would reoccur.

    Happy new year!

    Roger

    #44234
    Quote:
    However, I have now repeated the test to take screenshots and had the surprise to no longer observer changes.

    Make sure that you are also deleting your browser and server caches between tests.

    Quote:
    Instead, I used table cells with background colour.

    This is really bad practice. Tables are for tabular data.

    #44235
    flying_roger
    Member

    I did not delete the caches, but I refreshed the page.

    Fully agree on bad practice, this was the quickest workaround I could find.

    I reverted back to shortcodes after my previous msg.

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.