Return to Support

template issue

Home Forums Graphene WordPress theme Support template issue

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #2893
    Manasse
    Member

    Ok, Im trying to custom a template. U used the code for “one column, no sidebar” saying the following:

    <?php
    /**
    * Template Name: One column, no sidebar
    *
    * A custom page template without sidebar.
    *
    * @package WordPress
    * @subpackage Graphene
    * @since Graphene 1.0.5
    */
    get_header(); ?>

    <?php
    /* Run the loop to output the posts.
    * If you want to overload this in a child theme then include a file
    * called loop-single.php and that will be used instead.
    */
    get_template_part('loop', 'single');
    ?>
    <?php get_loop-single ?>

    <?php get_footer(); ?>

    I copied it renamed the “* Template Name: One column, no sidebar” part into “bandmembers no sidebar” Else. Named the .php file “bandmembers no sidebar.php” like this:

    <?php
    /**
    * Template Name: bandmembers no sidebar
    *
    * A custom page template without sidebar.
    *
    * @package WordPress
    * @subpackage Graphene
    * @since Graphene 1.0.5
    */
    get_header(); ?>

    <?php
    /* Run the loop to output the posts.
    * If you want to overload this in a child theme then include a file
    * called loop-single.php and that will be used instead.
    */
    get_template_part('loop', 'single');
    ?>
    <?php get_loop-single ?>

    <?php get_footer(); ?>

    Now, when I select my bandmembers no sidebar template in “new pages”, i get the sidebars I didn’t want…

    What am I doing wrong???

    #22483
    Manasse
    Member

    Thanks for replacing this in the support section. My error…

    The site I’m building is here: http://twowaysociety.nl/hidden/

    You can see the result of my template here : http://twowaysociety.nl/hidden/band/muco-2/

    Btw, on the index page I have chosen for the two-sidebar option through the theme’s options.

    Maybe it’s a default thing… I don’t know… that’s why I need help

    #22485
    Josh
    Member

    I love your background! The old style music page fading into darkness around the edges. Nice!!

    Okay, what I would do is use posts instead of pages, and then use a custom menu to arrange them however you like.

    By using posts instead of pages, you can individually set the template for each post. Then, in your custom menu, you can make them link (just like pages).

    Lemme know if you get stuck along the way. Ken has a great tutorial for custom menus here:

    http://blog.kjodle.net/2011/08/25/how-to-create-and-use-custom-menus-in-wordpress/

    #22487
    Manasse
    Member

    I cant seem to link to a google result, but the background was found while looking for free textures background (its a blogpost about this with 60 awesome high res pics)

    Anyway. Before doing what you’ve advised, I might take a look at what you’ve said in your other advise on my other post, since both are related.

    If it doesn’t help, Ill try what says above. I’ll keep you updated. BTW thamks for your Firebug tutorial!

    #22488
    Manasse
    Member

    Left a reply at the other thread. It explains why I don’t just want to categorize the authors and why I’d like to get a template work. You’re advise is a good alternative which I’m going to use if what I want just isn’t going to happen.

    For now, I’d still like to create templates. Above I used exactly the same php coding, but 2 different results. That shouldn’t happen, right?

    It’s giving me a headache, almost backflipped this pc. (I didn’t)

    Just don’t understand what goes wrong. Watched what happens with Firebug (used the html thingy) and discovered that my template DOES get the sidebars, just don’t know why…

    Thing I’m calling it a night… Maybe it’ll come tomorrow…

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.