Return to Support

Subscribe To Comments Reloaded / Subscribe2 with Graphene

Home Forums Graphene WordPress theme Support Subscribe To Comments Reloaded / Subscribe2 with Graphene

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #22203
    elarson
    Member

    Oops, I accidently delete the link I gave you for lable/input for “Notify me of new posts by email.” to appear before the “Submit Comment” button

    http://www.thinkspirator.nl/ellyn-test

    #2824
    elarson
    Member

    Hi Prasanna,

    Your site looks good. I have 2 questions for you that are off topic for this post, but I am hoping you can help me with them.

    1) I see that you are using the plugin “Subscribe To Comments Reloaded”. How did you get the comment-subscriptions page not to list the post twice? Here is my virtual page for comment-subscriptions: http://www.thinkspirator.nl/beheer-abonnementen (in Dutch). I have tried creating a real page to make the theme happy, without any luck. Any tips?

    2) I think you are also using the plugin “Subscribe2”? How did you get the lable/input for “Notify me of new posts by email.” to appear before the “Submit Comment” button? Here is an example of a post/comment page: http://www.thinkspirator.nl/test-from-ellyn. You will see it under the “Reactie Versturren” button as “Ja, ik wil graag op de hoogte worden gehouden van nieuwe artikelen”(in Dutch).

    Many thanks for any help you can give.

    — Ellyn

    #22204
    elarson
    Member

    I originally posted this comment to “General Talk / Slider on post/single page” after seeing the site of Prasanna at http://prasannasp.net I saw 2 things on his site with subscriptions that I wanted to get his input on, and I should have probably posted them to support. Please excuse the double posting/comment.

    Here is what I wrote:

    1) I see that you are using the plugin “Subscribe To Comments Reloaded”. How did you get the comment-subscriptions page not to list the post twice? Here is my virtual page for comment-subscriptions: http://www.thinkspirator.nl/beheer-abonnementen (in Dutch). I have tried creating a real page to make the theme happy, without any luck. Any tips?

    2) I think you are also using the plugin “Subscribe2”? How did you get the lable/input for “Notify me of new posts by email.” to appear before the “Submit Comment” button? Here is an example of a post/comment page: http://www.thinkspirator.nl/ellyn-test. You will see it under the “Reactie Versturren” button as “Ja, ik wil graag op de hoogte worden gehouden van nieuwe artikelen”(in Dutch).

    Many thanks for any help you can give.

    — Ellyn

    #22205
    Josh
    Member

    Hi Ellyn,

    (Moved your two posts from General Talk to Here).

    Yeah, I’ll let Prasanna handle this one… as I have no idea 🙂 He is very active in the forum, and there is a much better chance he will see your post here, rather than in General Talk.

    Also, feel free to message him on his site. He is quite the helpful one!!

    #22206
    elarson
    Member

    HI Josh,

    Thanks for moving the post. I’ve tried to contact Prasanna via the contact form on his site, but unfortunately, it’s not working. I guess I’ll just have to hope he logs in sometime soon.

    – Ellyn

    #22207
    Josh
    Member

    (Bumping back up to top hoping Prasanna will take a look.)

    #22209

    Message him on Twitter.

    #22210
    Prasanna SP
    Member

    Oh! I didn’t notice this thread earlier! I just thought that this reply was removed from my post!

    Well, here is the solution for your first question.

    Create subscribe.php file in your child theme (if you are using child theme) or in parent theme.

    Then add this to it.

    <?php
    /*
    Template Name: Subscribe To Comments
    */
    if (isset($wp_subscribe_reloaded)){ global $posts; $posts = $wp_subscribe_reloaded->subscribe_reloaded_manage(); }
    ?>

    <?php
    /**
    * The Template for displaying all single pages.
    */

    get_header(); ?>

    <?php
    /* Run the loop to output the posts.
    * If you want to overload this in a child theme then include a file
    * called loop-single.php and that will be used instead.
    */
    get_template_part('loop', 'page');
    ?>

    <?php get_footer(); ?>

    Then create a blank page with Subscribe To Comments template. And, go to Subscribe to comments Management Options and disable Virtual Management Page. Then enter the URL of the subscription page that you created above in the Management URL. Save changes.

    Now edit subscribe-to-comments-reloaded/subscribe-to-comments-reloaded.php file which is located in the plugin directory and replace ‘ID’ => ‘999999’ with the actual id of the subscribe comments page. (eg: 'ID' => '498'). Save file.

    And for your 2nd question, No, I’m not using Subscribe2 plugin. “Notify me of new posts by email.” is added by JetPack plugin. I can check the Subscribe2 plugin if you give some time.

    Thanks for notifying that my contact form is not working! I’ll check it now. And,, Yes! As Ken suggested, a message or mention on twitter is the quickest way to contact me! My twitter handle is @prasannasp

    #22211
    elarson
    Member

    Hi Prasanna,

    Many thanks for responding.

    It is working now using a actual page instead of a virtual page. I had tried this earlier, but missed that I needed to edit the subscribe-to-comments-reloaded.php with the actual id of the subscribe comments page.

    No worries about the Subscribe2 plugin. I have it working well enough.

    Regards and thanks,

    Ellyn

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.