Struggling with Adding Languages

  • dbphoto1981

    #7079

    Hi, I’ve added WPML to my site and have asked for French and Dutch as additional languages, but when i go to Theme plugin and locilalization it is showing the code of

    Quote:
    File not found

    but then says

    Quote:
    File Exists

    and I cant for the life of me get the small flags to show on my site at the top? Any help would be great, thanks 🙂

    Admin

    Syahir Hakim

    #36876

    You’re seeing something like this, correct:

    Fo7EV6W.png

    That’s because you don’t have the language files for WordPress in the wp-content/languages folder, but you do have the language file for Graphene in the theme’s languages folder.

    To make your site fully multilingual, you need to have at least two sets of language files, one for WordPress core and another for the theme. You can download the language files for WordPress core by downloading the language-specific WordPress package, and then upload those language files to the folder indicated above.

    See this page for language-specific WordPress packages:

    https://codex.wordpress.org/WordPress_in_Your_Language

    I said at least two sets because your plugins may need translation too, though the translation files for plugins (if they are available) are typically already included and set up along with the plugins, just like it is with themes.

    dbphoto1981

    #36877

    Thanks for that, I have just had a look and thewp-content/languages is not in there, do I create that folder, and copy in the language files? or do I have to actually install the other language? if so how do I do this without overwriting my site?

    Thanks 🙂

    dbphoto1981

    #36878

    Not to worry, I have installed it in that folder and made it. But now how do I get the language bar to appear in the theme where you can select it? Thanks.

    dbphoto1981

    #36879

    Am still struggling with this, I have installed:

    Theme Blvd WPML Bridge

    WPML Flag in Menu Extended

    WPML Multilingual CMS

    I now have the flags appearing, but when I click on a different language it gives me errors? let me know, the top drop down doe snot work but the menu at the bottom does? sorry, really stuck with this one??

    Thanks

    here is the page Page

    Admin

    Syahir Hakim

    #36880

    You really gotta ease up on the question marks there.

    Do you have any posts in French? The Nederlands language is working correctly. If you have posts/pages in French already, try going to WP Admin > Settings > Permalink and resave the setting.

    dbphoto1981

    #36881

    Sorry for all the question marks.

    I have solved the issue, but my problem now is I am trying to move the language selection from the menu to the top of the page (where the fb logo is) but it does not move when I select it to be in the top header? Thanks for the help 🙂

    Admin

    Syahir Hakim

    #36882

    Use the language switcher widget, and place it in one of Graphene’s action hooks widget areas.

    dbphoto1981

    #36883

    I have tried that but it still appears below the fb icon and almost as though it is in the header image?

    graphene_container_before
    graphene_before_feed_icon
    graphene_social_profiles
    graphene_top_search
    graphene_top_bar
    graphene_header
    graphene_nav_search
    graphene_header_menu
    graphene_top_menu
    graphene_before_content
    graphene_before_content-main
    graphene_top_content

    Which one of these would be the same as the facebook icon, and next to it?

    Admin

    Syahir Hakim

    #36884

    Try using graphene_social_profiles or graphene_top_bar. You’ll probably need some CSS adjustments afterwards to position it exactly.

Viewing 10 posts - 1 through 10 (of 10 total)

  • You must be logged in to reply to this topic.
Graphene Themes Forum