Strange Errors for a plugin–not sure if this is theme related

  • Anonymous

    #5047

    I was using the bbP Topic Views plugin, and it was fine; I had some other issues (speed and memory) and asked the host to migrate the site from windows to linux–and started getting the following strange errors when I clicked on a topic:

    Warning: session_start() [function.session-start]: open(/var/chroot/home/content/82/8351782/tmp/sess_2aorcel9g0ujkp4lkmd61nde50, O_RDWR) failed: No such file or directory (2) in/home/content/82/8351782/html/whup/wp-content/plugins/bbp-topic-views/bbp-topic-views.php on line 76

    Warning: session_start() [function.session-start]: Cannot send session cache limiter – headers already sent (output started at /home/content/82/8351782/html/whup/wp-content/plugins/bbp-topic-views/bbp-topic-views.php:76) in /home/content/82/8351782/html/whup/wp-content/plugins/bbp-topic-views/bbp-topic-views.php on line 76

    Warning: Cannot modify header information – headers already sent by (output started at /home/content/82/8351782/html/whup/wp-content/plugins/bbp-topic-views/bbp-topic-views.php:76) in/home/content/82/8351782/html/whup/wp-includes/pluggable.php on line 881

    Warning: Unknown: open(/var/chroot/home/content/82/8351782/tmp/sess_2aorcel9g0ujkp4lkmd61nde50, O_RDWR) failed: No such file or directory (2) in Unknown on line 0

    Warning: Unknown: Failed to write session data (files). Please verify that the current setting of session.save_path is correct () in Unknown on line 0

    Anonymous

    #30449

    Since your host moved your user account from windows to linux server, the address of your user directory is changed. (it happens). So, edit your database and change the path to home directory with the correct one. It will be in wp_options table.

    Anonymous

    #30450

    Thank you–where do I find the correct one’s address? Why doesn’t the plugin read the correct one? I did try deleting the plugin and reinstalling it, thinking it might be some such issue, but that didn’t help.

    Thanks again!

    Martin

    p.s. Where is wp_options? I couldn’t find it.

    Thanks!

    Anonymous

    #30451

    Create a file named absolutepath.php in your home directory and put this code and save.

    <?php
    echo __FILE__;
    ?>

    Then call that file (http://yoursite.com/absolutepath.php). It will output something like this,

    /home/content/xx/xxxxxxx/html/absolutepath.php (there will be some numbers in the place of xxxxxxxx)

    If you remove the /absolutepath.php part, the remaining will be your absolute hosting path. i.e /home/content/xx/xxxxxxx/html`

    Then open phpMyAdmin and replace your old absolute path with the above one in the WordPress database. But be careful while editing MySQL database. If you fail to edit the database correctly, you may lose all your wordpress data including posts, pages and comments. If you feel it is difficult to do it yourself, get the help of a friend/professional or simply ask your host to do so.

    Anonymous

    #30452

    I contacted the host, and the problem was somewhat different; here is what they wrote:

    Quote:
    Thank you for contacting Online Support. I understand you are receiving an error on your site. I have reviewed your hosting plan and show your hosting plan’s absolute path is fine, but the tmp folder was missing from your account. We have restored this for you, and your site appears to be running properly now.

    Th problem is resolved.

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.

Do NOT follow this link or you will be banned from the site!