Store not working.

  • bjeffries

    #4417

    I use shopplugin and with this theme 1.6.2 I believe is the version number, I cannot add items to my cart, and you do get an item in your cart you cannot proceed to checkout or add another/multiple item to your cart. This is the error: “There are currently no items in your shopping cart.”

    I have a feeling shopp support is going to push it off as not their problem because it is a theme issue. Would you know what this could possibly be? I was thinking cookies but I could be wrong.

    http://motodude.com/store/

    Thanks,

    Brian

    bjeffries

    #28151

    Anyone having similar issues?

    Mod

    Kenneth John Odle

    #28152

    Right click disabled again. Can’t tell a thing.

    Disabling right clicking does nothing to prevent someone from stealing your images or text.

    bjeffries

    #28153

    ok try it now.

    The goal is not to stop them, it is to make it more difficult. I can still save images without having right click abilities but some people may not know how to do that, including the person I build this site for.

    Mod

    Kenneth John Odle

    #28154

    I know, but it’s like SEO or validation: people think they have to have it although it is often pointless and sometimes downright worthless (and annoying!)

    So I clicked on the “Evolution” shirt, added two to my cart, then “Continued Shopping” and added “Whoop de Chews” shirt, and then went to the checkout. That’s when I got the “There are currently no items in your shopping cart.” message.

    Okay, I thought “maybe it’s because I’m not registered”. So I tried to register, so that I could do this while I was logged on. I used the name “ken-test” and an email address that I rarely give it out. I got this message: “This username already exists. An account with this email has already been registered.”

    That is possible, but highly unlikely.

    So there is a problem with both shopp and the simple registration form. I would try disabling the latter and seeing if your cart problems go away. It could be a plugin conflict.

    I have a feeling shopp support is going to push it off as not their problem because it is a theme issue.

    This is my experience with most ecommerce plugin developers. But it may not be a theme issue as much as it is a theme/plugin conflict or plugin conflict.

    (Your “meta property=’og:description'” is wonky, btw.)

    bjeffries

    #28155

    oh jeez, haha. I did disable all the plugins to test the shop and that didnt solve the problem. But now that there is a registration problem I am unaware of I will also try to look into that. But that may be more difficult than I expected, if I disable simplr registration, then I need to redirect the people (or me temporarily) to the default wordpress registration, which doesn’t give them the option to create a username, first and last name (unless that has changed with newer versions of WP)

    AS for the cart issue, I did notice other people can add multiple items, I however cannot, which must be my particular browser settings or something. I will try to just disable the simplr registration form and give the cart a try again, but I disabled everything before with no luck.

    “(Your “meta property=’og:description'” is wonky, btw.) “

    I have no idea what that is, I use the SEO by Yoast I think its called so that must be rendering that code.

    I am thinking about switching over to woocommerce: http://www.woothemes.com/woocommerce/ since I am having terrible luck with this shopplugin, I am pretty sure that will also not be compatible with this current theme, but I think I may just resort to using a child theme just for the store. Have you heard of this plugina and know if it is any good?

    I will get to these issues tomorrow. Thanks for your help and patience.

    bjeffries

    #28156

    Ok, so I got the login fixed, I am no longer using simplr registration, I am now using WP User Control which seems to work fine.

    I am now just getting the error “There are currently no items in your shopping cart.” I am using my child theme and getting this error and the unedited 1.6.2 theme and receiving the same error. When I switch to Twenty Eleven theme I do not get this error. I did all this with plugins activated and not activated, makes no difference.

    Would you know what it could be at this point?

    bjeffries

    #28157

    Would you know what it could be at this point?

    bjeffries

    #28158

    Would you know what could possibly be done to get this to work?

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.

Do NOT follow this link or you will be banned from the site!