Stop widgets in the graphene_after_post_content from appearing in excerpts on home page

  • AHumaciu

    #10175

    I added the graphene_after_post_content in the Settings/Advanced section. I finally get the widgets to appear in the order I want on my posts (YEAH!)

    BUT… they also appear on the excerpts on my home page. (example: http://munofore.com/ ) I just wrote in a text widget “Post Footer Text” so you could see what I mean.

    I saw another post about this from a year ago, https://forum.graphene-theme.com/graphene-support/how-to-enable-graphene_after_post_content-widget-area-only-in-posts-and-not-in-excerpt

    I posted the code from that thread in the Custom CSS section on the Display page but it is still appearing on the home page. Did I put the code in the wrong place?

    Ultimately I am trying to get my Related Posts widget to appear above the ProGrids advertising widget on my posts and was hoping action hooks would solve my problem. Is there a better way? (I know that is technically two questions, but I thought knowing my reasoning might be helpful).

    Mod

    Kenneth John Odle

    #45558

    You are using a different widget area than that post. This code should work:

    .home #graphene-dynamic-widget-graphene_post_footer {display: none;}

    Is your server located in the EU?

    AHumaciu

    #45559

    Thanks for the quick reply.

    Oops! I had clicked the wrong hook. Unfortunately even when I changed it to the graphene_after_post_content, which is what I wanted, with the code in my original comment it is still appearing just in a slightly different place. 🙁

    My server is in the US (Los Angeles)

    Mod

    Kenneth John Odle

    #45560

    Try

    .home #graphene-dynamic-widget-graphene_after_post_content {display: none;}

    Quote:
    My server is in the US (Los Angeles)

    Unless it’s a California thing, you don’t need the cookie notice. That’s only an EU thing.

    AHumaciu

    #45561

    And here is proof that Punctuation Matters!!! ha ha!

    It is working fine for this site and for my other one, except for my most recent post. Which for some bizarre reason is showing the ProGrids widget on the home page 8 times(http://www.thatrecipe.com/blog/ if you want to see)! But it appears once on the actual post, and the rest of the Home Page is correct. I will live with it for now and just disable ProGrids if I keep having issues.

    THANKS!

    And thanks for the info about the Cookie Policy, I keep getting conflicting information since I have readers in many EU countries.

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.

Do NOT follow this link or you will be banned from the site!