sticky post & slider issue

  • duskinchains

    #2031

    Hi,

    If I make a post sticky, then the link on the slider for read more always goes to the sticky post instead of the post excerpted. I am probably missing something.

    Admin

    Syahir Hakim

    #18273

    Try updating to version 1.5.3 and see if the problem persists.

    Anonymous

    #18274

    Hi lindseyb16,

    1. In your sticky post… are you using the “more” link. Or are you creating an excerpt?

    2. In your slider pages/posts… same question. Are you using the “more” link or creating excerpts?

    lindseyb16

    #18275

    Thanks for your answers, the theme is up to date.

    There is no more link in the sticky post. And I am creating excerpts on the slider.

    Check it out on the site, when you click on the “read full post” on any of the articles on the slider it goes to the permalink for the sticky post. http://www.thedigitalbackpack.com

    Anonymous

    #18276

    Hmm… I just tested mine and it worked fine.

    What option do you have selected in your options menu under “slider options” for the second item… “What do you want to show in the slider”?

    lindseyb16

    #18277

    Hi,

    I have show posts from categories, and I have two categories selected that I want to feature, learn & teach.

    If you can’t find anything obvious, I don’t have to make the post sticky, I can just make the post feature in the slider by changing the option in the slider to show specific posts.

    Interestingly if you click on the title of the post in the slider it goes to the correct permalink, it is just the button in the slider that doesn’t.

    Anonymous

    #18278

    Yes, I noticed that also. Strange indeed. It must have something to do with that category option. I’ll investigate further and wait to see if Syahir knows a simple solution.

    In the meantime, you can still keep your posts as sticky… just use the “show specific posts/pages” option. Enter your post and page id’s, in the order you want them shown, and everything should link properly.

    lindseyb16

    #18279

    OK, thanks for your help, glad I found this forum.

    Mod

    Kenneth John Odle

    #18280

    And I am creating excerpts on the slider.

    I’m not quite sure what you mean by this.

    I just updated to 1.5.3 on my book blog and I have a sticky post and I’m not seeing the problem, nor can I replicate it. This might be a permalinks issue. What are your permalinks settings? Try taking that “blog” out of there and see if this takes care of the problem.

    Admin

    Syahir Hakim

    #18281

    The exact same code is used to generate both the links on the title and the button. The only reason I can think of that would result in this behaviour is that somehow something’s changed when the excerpt is displayed in the slider.

    And looking at your site, I bet it’s the plugin that inserts the “Share and Enjoy” buttons is the one that changes the query and didn’t reset it after it’s done. Try disabling it and see if the problem goes away.

Viewing 10 posts - 1 through 10 (of 11 total)

You must be logged in to reply to this topic.

Do NOT follow this link or you will be banned from the site!