Sticky post not showing content

  • Stylite

    #4569

    Now my Graphene theme is working correctly again, I have another quest.

    I would like to display a ‘welcome message’ on the homepage, as a sticky post.

    However, when I set a specific post to sticky, its content disappears.

    Looking into the HTML, it appears that the whole entry-content div is never called for.

    The div just doesn’t appear in a sticky post.

    I looked into the PHP of the theme, but little is said about sticky posts. It seems like they are handled just like regular posts. I looked in the files of WordPress, but got lost. I wonder: is it standard, that sticky posts don’t show content?

    I would like them to do so. Can you help me with this?

    Mod

    Kenneth John Odle

    #28525

    Please post a link to a sticky post where this is happening. It’s really hard to figure out without seeing it live.

    Stylite

    #28526

    Hi Kenneth,

    sure, I know that’s a better way.

    It’s only that the site is live, and I don’t have a test environment.

    I will look if I can somehow set up a test post on the front page without making visitors confused. I’ll let you know.

    Stylite

    #28527

    Ok, I have added a ‘test message’.

    http://manegehetroessingh.nl/

    The header line reads ‘Test message (expires on …)’.

    The content and the excerpt contain some lines of text.

    If you need more info, just respond, and I’ll be back. Thank you on beforehand!

    Prasanna SP

    #28528

    1. Deactivate “Simple Social Buttons” plugin.

    2. Add some content in the “Excerpt Area” of that sticky post.

    Stylite

    #28529

    Thanks; I have deactivated the Simple Social Buttons plugin. If it is buggy, there are other social button plugins.

    However, I have some text in the excerpt. In the content as well. I just can’t figure out why it doesn’t show it.

    I update WordPress regularly and have no customizations in it.

    I have the following plugins:

    – Capability Manager 1.3.2

    – Custom Post Order 2.2

    – Custom Post Type Archives 1.5.1

    – Easy Contct Forms 1.3.1

    – List category posts 0.24

    – MaxButtons 1.6.0

    – Meta tag manager 1.2

    – NextGEN Gallery 1.9.3

    – Slimbox Plugin 1.3

    – Twitter Tracker 2.2

    – Ultimate Post Type Manager 1.6.9

    – WP Maintenance Mode 1.7.1

    I’m wondering. I have a Graphene child theme, made according to the WP tutorial on child themes. Do the settings I do in my child theme (I mean I still have the ‘Graphene settings’ option in my menu) override those I once set on the Graphene theme itself?

    Although I have just run through all Graphene settings and there is no one in particular about showing stickies in some way, I thought there may be a setting gone wrong… or can’t it be?

    I’m checking through my css now, but it would be impossible if it were in there; in that case, I would see the HTML in the source, only hidden.

    Stylite

    #28530

    Do you know perhaps where this sticky post is put together? Is it in the theme file, or is it in the WordPress core? Because it’s odd that the complete content-content and the excerpt-content are just not there.

    darzan

    #28531

    Same problem to me.

    I fixed it by commenting lines from 24 to 38 in index.php

    but the problem persists in category listing pages.

    Admin

    Syahir Hakim

    #28532
    Quote:
    Same problem to me.

    I fixed it by commenting lines from 24 to 38 in index.php

    but the problem persists in category listing pages.

    What version of the theme are you using? Link to your site?

    cuttsn

    #28533

    I have the same problem, but for me it seems to be linked to Graphene Options – Front Page Post Categories. As soon as I select only certain categories to sow on the front page, the sticky doesn’t show. It doesn’t make any difference whether the sticky is included or not in the list of categories to be listed. Any ideas? Site is http://www.music-health.org

Viewing 10 posts - 1 through 10 (of 12 total)

You must be logged in to reply to this topic.