Static Home Page with Separate Blog Area

  • speedy

    #2599

    Hi. This is my first time making a website and I love the Graphene Theme – it’s been pretty user-friendly for me and my husband. We’re stuck now though. Our site is ScienceGetaways.com. We want the main landing page to be a static page, and we want to set a different location on the site to be the blog. We followed the instructions at http://codex.wordpress.org/Creating_a_Static_Front_Page to do this: we created a static front Page, and created a second Page called “blog”. In the codex instructions, it says to leave that Page blank, as it will be ignored.

    Great so far. But what we want is to have a blog on the site, but NOT on the front page. We want another URL, say sciencegetaways.com/sgblog, where the blog posts will go. Also, we want to make sure that static pages don’t allow comments, but people CAN comment on the blog.

    We’ve seen instructions on how to do this, but they’re usually incomplete, and when we tried we had blog posts showing up on the blog page and on the home page, even though it was set to be static. Also, in our top directory are all the usual wp-admin files and all that; the only php file we have is index.php.

    The site is active, and we’d prefer not to have to start all over again! Is there a way to add a blog with comments turned on, but keep the rest of the site the way it is?

    Mod

    Kenneth John Odle

    #21075

    Your blog is the name of your website, plus the page you selected to be the blog. If you set “sgblog” to be the blog page, then your blog is located at “sciencegetaways.com/sgblog”. Mine is at kjodle.net/blog.

    SG

    #21076

    Right – we did that and now we’ve got blog posts on that page (sciencegetaways.com/sgblog)and on the static home page (sciencegetaways.com). How do we get the blog posts to not show up on the static homepage? Also, there was no comments area on the sgblog page we created, although the posts did show up, which is a start.

    Thanks!

    Mod

    Kenneth John Odle

    #21077

    Graphene Theme Options >> General >> Homepage Panes >> Number of latest posts to display

    Set this to 0.

    SG

    #21078

    I set the number of posts to display to 0, but it still displayed the blog post on the home page, so I disabled homepage panes and I think that fixed it. I still can’t find how to turn on comments on the blog and I’d also like to be able to change who the post is by because sometimes I’ll be blogging and sometimes my husband will do it. Any ideas on those 2 issues? Thank you so much for your help!

    SG

    #21079

    OK – I’m getting closer. I finally figured out how to turn on comments for just the blog, now the only issue is how to change name displayed for different authors of different blog posts.

    Josh

    #21080

    Well, can’t you create another user?

    Just add a new user with your husband’s name. Give him the same access as admin.

    Then, when he logs in to create a post, it will have his name as the author.

    (Ken, correct me if I’m wrong)

    Mod

    Kenneth John Odle

    #21081

    No need to correct you, Josh, you are absolutely correct. In fact, you can even go back and edit previous posts and assign them to a different author.

    SG

    #21082

    Thanks guys. I created another user and set the post edit page to display authors (Post – Edit – Screen Options (dropdown in upper right) – check Author. Your help is greatly appreciated. My site is done and I love it!

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.