Return to Support

Slider won't dislay image +

Home Forums Graphene WordPress theme Support Slider won't dislay image +

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #2851
    HayManMarc
    Member

    It seems I’ve tried everything, but I can’t get the slider to display the image from a post.

    Also, can I put ‘static pages’ in the slider? The Graphene Theme Options give the option to “Show specific posts/pages” with “Enter ID of posts and/or pages to be displayed, separated by comma. Example: 1,13,45,33” for the field to enter the ID into. I can’t for the life of me find that ID number, for even the posts. Through trial and error, I’ve punched in random numbers and was able to display posts, but never an image that was within that post would display.

    Can someone walk me though this? I think I’ve figured everything else out.

    My site: http://haymanquarterly.com/blogs/

    #22262
    Josh
    Member

    Hello,

    You can find the ID of a post/page by going to the admin panel and clicking on posts or pages (depending on which one you want to use). Then, hover over a post/page, but don’t click on it. While hovering over the title, look at the lower left of your browser window and you will see a link. In this link is the ID of the post/page you are hovering over.

    You will see something like post.php?post= followed by a number. That’s the ID.

    Alternatively, you might wish to give my plugin a try. It will add a column for the ID in both your posts screen and your pages screen. It can be downloaded using the little banner below my post here.

    #22263
    HayManMarc
    Member

    Thanks Josh!

    I found the ID number and got my pages to display, but text only. I still cant get the images to show. I’ve selected images in each page to be the “featured image” of that page. I’ve adjusted the settings in “Graphene Theme Options” appropriately.

    Copy & Pasted the entire “slider options” tab as it is:

    Disable slider [ no ]

    What do you want to show in the slider

    Show latest posts

    Show random posts

    —> Show specific posts/pages

    Show posts from categories

    Posts and/or pages to display [ 65,113,140,154,78 ]

    Enter ID of posts and/or pages to be displayed, separated by comma. Example: 1,13,45,33

    Applicable only if Show specific posts/pages is selected above.

    Number of posts to display [ 5 ]

    Slider image [ Featured Image ]

    Custom slider image URL [ http://haymanquarterly.com/images/UFOMainMenu.PNG ]

    Upload or select image from gallery – Make sure you select Custom URL in the slider image option above to use this custom url.

    Slider display style [ Background image and excerpt ]

    Slider animation [ Horizontal slide ]

    Slider height px [ left blank ]

    Slider speed milliseconds [ 8000 ]

    This is the duration that each slider item will be shown

    Slider transition speed milliseconds [ 500 ]

    This is the speed of the slider transition. Lower values = higher speed.

    Move slider to bottom of page [ no ]

    Any idea why the images wont show?

    #22264

    Any idea why the images wont show?

    Possibly because they are png instead of jpg?

    #22265
    Josh
    Member

    Well, to use just one image, like the url you provided above, you would want to change the “slider image” from ‘featured image’ to ‘custom url’.

    Here is what I do, which provides maximum control:

    1. In graphene options, set “slider image” to ‘custom url’, and leave the box below it blank.

    2. On each post/page I use in the slider, there is a box below the editor called “Graphene page-specific options”.

    3. Here, I choose “custom url” and enter the url to my custom image (mentioned below).

    4. I then make a custom image for that post/page. I use Photoshop. Your particular slider images should be 445px wide and 240px tall.

    5. Create a separate image for each post/page to display in the slider, and make sure that post/page is set to use the appropriate image via the custom url setting.

    Sounds like a lot of work, but goes pretty fast once you get the hang of it.

    You can check my page to get an idea of how it works.

    http://www.joshlobe.com/

    #22266
    Josh
    Member

    Possibly because they are png instead of jpg?

    Yeah, I just double-checked my custom images made for my slider, and they are jpg format. I usually always try to use png format, so it’s strange I used jpg. This could have possibly been the reason.?

    #22267
    HayManMarc
    Member

    Ooohhh, okay, So the image size is probably the culprit. I’ll try that first. If that doesn’t work, I’ll change the file format from .png to .jpg. If still no luck, I’ll try rearranging the settings as you described. I’ll post back after and let you know the winner. 🙂

    Thanks, man.

    #22268
    HayManMarc
    Member

    Thank you, thank you, thank you. Image size is the winner!

    I created thumbnail images of 445 x 240 and the image displayed. Did NOT need to change file type. PNG works fine.

    Also, I rearranged the settings as you directed. I couldn’t test it without doing so because the new images won’t be on the page. But come to think of it, I guess that wouldn’t matter. I would have still needed to change the “featured image” URL, if I had gone that route.

    Anyway, it’s working now. Thanks again! Pretty cool theme.

    #22269
    Josh
    Member

    No worries.

    Do one more thing… Paste this code into the custom css box in the admin panel graphene options section:

    .sidebar div.sidebar-wrap {
    border: none;
    }

    It will make all the widgets have a less “sharp” appearance. Experiment with it on and off and see what you think.

    #22270
    HayManMarc
    Member

    Wow! That’s beautiful. Thanks. I downloaded your editor, BTW. Too late now, must sleep. I’ll check it out tomorrow. It looks very nice.

    Thanks Josh. You da man! 🙂

Viewing 10 posts - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.