Slider problem

  • Cooperman

    #2377

    I generated a slider item from a post which worked OK initially but when I put another image above the one that was previously first in the post the slider would not change the thumbnail to the new first image. I’ve tried deleting and reinstalling the images in question in the post but the slider image won’t change

    Josh

    #20003

    I thought the default of Graphene was to use the first image in a post, unless otherwise specified. (Ken??)

    You can always manually override this by using the “featured image”. On the post you want to show in the slider, click featured image and set an image.

    I believe the slider will use this image regardless of any other images in your post.

    Cooperman

    #20004

    I tried using featured image and the same thumbnail then appeared in every post on the slider, not just the post in question

    Josh

    #20005

    On each post/page you want to display in the slider:

    1. Below the edit box is “Graphene post/page specific options”.

    2. Slider Image – Set to featured image

    3. Do this for each post/page you are displaying in the slider.

    4. Make sure each post/page has a different featured image.

    5. Report Back 🙂

    Cooperman

    #20006

    I mongrelised your suggestion and opted for a custom url with a link back to the image in my upload folder. It worked and meant that I didn’t have to alter any other posts either. So that’s a fix but still doesn’t explain why you can’t change the first image in a post and have it appear in the slider.

    Thanks

    miekoh

    #20007

    I set my option to “Thumbnail and Excerpt” however, not all but some shows too much writing and makes “View More” icon disappears. What am I doing wrong? Or, is that the way supposed to be?? It would be nice if we have an another choice like “thumbnail and Title only” 🙂

    Josh

    #20008

    @ miekoh,

    Please see this thread on using a filter to limit the amount of text shown in the slider.

    http://codex.wordpress.org/Function_Reference/the_excerpt#Control_Excerpt_Length_using_Filters

    You will need to setup a child theme, and add the code to your functions.php file.

    (You can always start a new thread with a new question; it will get viewed, and answered, a lot faster)

    miekoh

    #20009

    Thank you Josh!

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.