Slider NOT correctly selecting the First Image in a post.

  • Tim Beresford

    #8126

    Can anyone suggest what might be going wrong?

    My slider, at the top of my home page, is failing to select the FIRST image in the post as the slider image, even though that is the selection I have made in the “Slider Options” parameter setup of the Graphene Options section in my dashboard.

    Instead, a seemingly random image from the post is being selected.

    Has anyone else encountered this, and found a solution?

    Could it be something to do with which post image was UPLOADED to the Media Library first? (I’m clutching at straws here – just trying to imagine what the code for the slider is doing and why it might not correctly select the first image actually placed in the post).

    Any help would be appreciated.

    Tim Beresford.

    Admin

    Syahir Hakim

    #40433
    Quote:
    Could it be something to do with which post image was UPLOADED to the Media Library first? (I’m clutching at straws here – just trying to imagine what the code for the slider is doing and why it might not correctly select the first image actually placed in the post).

    That is indeed the case, and it is by design as it is the fastest and most reliable way of getting a post’s image (other than Featured Image, of course). You can also rearrange the images uploaded for a post so that an image that is uploaded later can still be selected by placing it first in the list of images uploaded for the post.

    Tim Beresford

    #40434

    Hello Syahir.

    Many thanks for your reply.

    I have just searched the support forum but can find no instructions as to how to rearrange the images in the Media Library, and I’m afraid there is nothing on the dashboard of Graphene to suggest how this might be achieved.

    I would be grateful if you could point me in the right direction for some instructions onhow the Media Library ‘position’ data can be found and altered.

    Many Thanks,

    Tim.

    Admin

    Syahir Hakim

    #40435

    Go to the Edit screen for the post, and click on the “Add Media” button. In the dropdown with the “All media items” preselected, choose the “Uploaded to this post” option instead. To rearrange the images, simply drag and drop them in the desired order. The first image should be located leftmost.

    Tim Beresford

    #40436

    Thank you, Syahir.

    That worked just fine.

    You are a star!

    Best Wishes.

    Tim.

    Prasanna SP

    #40437

    Marking thread as resolved. You can do this yourself as well.

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.