Show image in excerpts

  • Anonymous



    I have a small issue. I can’t find how to show images in excerpts. There is option “Retain these HTML tags in excerpts” in excerpts display options. But then I write img tag there, image appears in excerpts and in slider, but I have custom image for slider so I dont want any more images in slider. Is there any easy solution for showing first post image or maybe custom field image in excerpts.

    Any help would be greatly appreciated and sorry for my english.

    Uh… This post should be in WordPress theme, not Mobile. Sorry for that.



    Thread moved to Graphene Support


    Syahir Hakim


    Link to your site?




    Prasanna SP helped me a lot. I thank him one more time. 🙂

    Solution for my problem:

    Add in Retain these HTML tags in excerpts and put this CSS in Custom CSS or in child theme style sheet.

    .featured_slider img {

    display: none;
    .sliderpost_featured_image, .sliderpost_featured_image img {

    display: block !important;

    I don’t know why, but I couldn’t resize images in excerpts. WP-Admin -> Settings –> Media Settings –> Thumbnail size function didn’t do anything, no matter how I changed dimension. So I resized them using CSS. Here is code:

    .home  .entry-content img, .home  .child-page img {
    width:150px !important;
    float:left !important;
    margin: 0 15px 5px 0 !important;

    Thank you guys. You are doing great job and I love your theme.

    Best regards,


Viewing 4 posts - 1 through 4 (of 4 total)

  • You must be logged in to reply to this topic.
Graphene Themes Forum