Show full post on home page

  • alisoncerier


    Great theme..very clean and usable.

    I would like to have the home page show the slider and then one full post. I’ve almost accomplished this by setting the home page to display a category that has only one post in it (our hottest info). But only the excerpt shows up, with a “Continue Reading” button, even if the full post is very short. Any way I can display the complete post on the home page?



    Syahir Hakim


    This is a bug with the current version. I’ve fixed it and will be available in the next update.



    I would also like to show full posts on the home page. Has this bug been fixed? I am running Graphene 1.3.1.

    As an alternate to full posts on the home page, is there a way to alert someone where there’s an attachment (video, audio, etc.)?



    Hi, I’m also curious about this. I’m planning to show embedded youtube screens on front page panes, but it just keeps showing the post title and a read more -button, and there is no other content except the embedded youtube code in the post. When you click the post, it shows the embedded youtube content as it should. But I want that to show directly on my front page.

    I’m running WordPress 3.2.1. and Graphene 1.4.1.

    Please, let me know whether this is possible or not. Also, any workarounds are appreciated!


    Syahir Hakim


    Do you have the Graphene Options > Display > Show excerpts in front page setting unchecked?



    Hi. I didn’t, now I do. But there seems to be no effect on that matter whether it’s checked or not…


    Syahir Hakim


    URL to your site?



    I’m having the same problem as temgesic. The ‘show excerpts in front page’ setting is unchecked, but it continues to show just the post title and a “Read More” button, this then links to the post page to show the content.

    I thought it might be to do with a conflict with another plug-in, but I’ve tried it with just a regular post and still the same thing.

    The site in question is



    Syahir Hakim



    It seems that you are using a static front page, but the page you’re using for that doesn’t have any content. Try adding some content or just use the default posts listing instead of Static Front Page.




    Yes, I am using a static front page. I didn’t want any content on it apart from the latest post. I tried adding some static content, and using the page pane, but the full post content is still not showing up. (It is fine on the listings/archive page).

    I only want 1 post on the front page, but if I use the default listings page I get all of them, unless I change the WP settings but that effects ALL post listings, which I don’t want to do.


    Syahir Hakim

    I didn’t want any content on it apart from the latest post.

    Try using the Custom Post Limits plugin. It lets you specify different post limits for different pages.

Viewing 11 posts - 1 through 11 (of 11 total)

You must be logged in to reply to this topic.