shortcode in search results

  • KevinN

    #3697

    I have a site that uses custom fields and shortcodes for a great deal of my content. The mobile theme works really well, when I do a search the excerpt is shown but the shortcodes do not render.

    Any help would be greatly appreciated

    Prasanna SP

    #25566

    Either select “Show full content on archives” or add that short code in Graphene Excerpt display options –> Retain these HTML tags in excerpts. Chances of getting the second solution to work is almost 0 as the short codes are not HTML tags.

    KevinN

    #25567

    “Show full content on archives” was only available on my main Graphene Theme. When I selected it, this did not help anything in the mobile theme.

    Additionally I do not want this on my main graphene theme.

    Prasanna SP

    #25568

    Oops! I didn’t observe that it is a Graphene Mobile support question. Sorry..

    Admin

    Syahir Hakim

    #25569

    Hi KevinN,

    I will add the “Show full content in archive pages” option as well as the “Retain these HTML tags in excerpts” to the mobile theme in the next update.

    KevinN

    #25570

    Thanks so much! For now I’ve created a graphene-mobile child theme and added

    add_filter( ‘the_excerpt’, ‘shortcode_unautop’);

    add_filter( ‘the_excerpt’, ‘do_shortcode’);

    to the functions.php file.

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.

Do NOT follow this link or you will be banned from the site!