rtl/arabic

  • rtober

    #311

    Hi,

    I’m new to WordPress and just installed Graphene. How do I get the theme to be rtl without changing admin language?

    thanks!

    Admin

    Syahir Hakim

    #12079

    Hi,

    Just change the WordPress language to the RTL language (I assume Arabic?), and install the Admin in English plugin by Nikolay Bachiyski to keep the admin panel in English.

    Kadi

    #12080

    Thanks, Syahir. Yes, it is in Arabic.

    Is there an Arabic translation for the theme? Also Arabic fonts look very small in the navigation bar. How can I make them larger?

    btw the theme is very user friendly…thank you so much!

    Admin

    Syahir Hakim

    #12081

    Nope, I have just added full RTL support for the theme in the last update, so there is no RTL languages translation yet.

    Perhaps you could make one for Arabic? 😀

    Kadi

    #12082

    I would but I don’t know how.

    I still need help with small fonts in the nav bar, please.

    Admin

    Syahir Hakim

    #12083

    Implement a child theme, and then add the following CSS code to the child theme’s style.css file:

    #menu li a, #menu li a:visited{
    font-size:14px;
    }

    Obviously, change the font size to whatever size that you want.

    There’s instructions on how to translate the theme here.

    Kadi

    #12084

    Thank you so much!

    When I complete customizing and translation, I’ll let you know.

    (unless someone beats me to it 🙂

    Admin

    Syahir Hakim

    #12085

    Great! I’m looking forward to it!

    PS: I received the theme’s first RTL language translation yesterday, which is the Persian language (fa_IR) 😀

    Kadi

    #12086

    Hi again,

    I translated the front end terms of Graphene and saved it as a .mo and .po file. I uploaded both files in the language file but the translations aren’t appearing.

    Sorry I’m new at all this. Not sure what to do.

    Admin

    Syahir Hakim

    #12087

    I’ve made a video tutorial on how to use languages other than English with your WordPress installation here: http://www.khairul-syahir.com/topics/tutorial/2011/using-other-languages-with-wordpress.html

    Kadi

    #12088

    Thanks, I did that and it worked, but the layout is messed up now! :/

    Please take a look.

    http://www.ms-saudi.org/wordpress/

    Admin

    Syahir Hakim

    #12089

    Hurm..when using child theme, the theme’s rtl.css file is not loaded by default. To enable it, create a new file called rtl.css in your child theme’s folder. Then add the following code inside that file you just created:

    /*
    Theme Name: Graphene Child
    Template: graphene
    */

    @import url("../graphene/rtl.css");

    Reference: http://codex.wordpress.org/Child_Themes#Note_on_RTL_support

    Kadi

    #12090

    I had already done that. 🙁

    Admin

    Syahir Hakim

    #12091

    Hurm..it seems that you have done everything right, but somehow WordPress is not loading the child theme’s rtl.css file.

    In that case, just add this line right after the @import url("../graphene/style.css"); line in your child theme’s style.css file:

    @import url("../graphene/rtl.css");

    It’s a hack, and adding that means that your child theme will always load the rtl.css file, regardless of the language being used.

    Kadi

    #12092

    that fixed it! thank you!

Viewing 15 posts - 1 through 15 (of 18 total)

You must be logged in to reply to this topic.