removing pages from my WP Graphene website

  • trailsnet

    #6247

    I would like to remove some pages from my website, but I’m not sure if I’d like to completely delete them. I may use them again later. So I’d just likely to temporarily make them disappear from the publicly viewed headers & sub headers of my site.

    I have tried the following:

    1.) going to the main menu in the menu page and clicking on the Remove button for each page, then hitting the Save Menu button. I have tried this numerous times and it just takes me to a blank page with no error message. Then when I go back to the site, the pages are still there.

    I would appreciate any suggestions.

    Frym1

    #33787

    Go into dashboard > appearance > Editor > Theme Functions and place the following code into function.php (need to remove 55 and place your page number there).

    <?php wp_list_pages('depth=1&sort_column=menu_order&exclude=55&title_li=' . __('') . '' ); ?>

    Or

    Download a Plugin called Exclude Pages from Navigation. Great Plugin.

    Mod

    Kenneth John Odle

    #33789
    Quote:
    Go into dashboard > appearance > Editor > Theme Functions and place the following code into function.php (need to remove 55 and place your page number there).

    Do NOT edit theme files. If you know what you’re doing, your changes will disappear at the next update. If you don’t know what you’re doing, just about anything could happen.

    There is no need to make this complicated. Just edit the page, and in the “Publish” pane, set the page’s status to either “Draft” or “Pending Review”. Mischief managed.

    Entities must not be multiplied beyond necessity.

    Mod

    Kenneth John Odle

    #33790

    This method will remove the pages in question from your site and from your menu. If you have pages that you would like to have published without having them appear in a menu, use a custom menu:

    http://blog.kjodle.net/2011/08/25/how-to-create-and-use-custom-menus-in-wordpress/

    trailsnet

    #33791
    Quote:
    Go into dashboard > appearance > Editor > Theme Functions and place the following code into function.php (need to remove 55 and place your page number there).

    Do NOT edit theme files. If you know what you’re doing, your changes will disappear at the next update. If you don’t know what you’re doing, just about anything could happen.

    There is no need to make this complicated. Just edit the page, and in the “Publish” pane, set the page’s status to either “Draft” or “Pending Review”. Mischief managed.

    Entities must not be multiplied beyond necessity.

    Thanks for reminding me. I tried this, too, but it didn’t work. I changed the status to Draft, then updated and the pages are still there. I even tried changing the visibility to private, then updating. That didn’t work either.

    I’m glad you recommended NOT editing theme files because I definitely fall into the “don’t know what I’m doing” category. Plus you have a good point, the changes would just disappear @ the next update anyway.

    So now I’m back to where I started. I still can’t make the pages disappear.

    Prasanna SP

    #33792

    Pages –> All Pages , Quick Edit the page which you want to hide and select Draft in Status

    trailsnet

    #33793
    Quote:
    Download a Plugin called Exclude Pages from Navigation. Great Plugin.

    I was sure this one would work, but I downloaded the Plugin & activated it and…

    It didn’t work. The include page checkbox showed up on my pages, but when I unchecked the box and updated, then I reloaded the web page, the excluded page was still there. Very frustrating. I thought this would be the ultimate solution.

    trailsnet

    #33794
    Quote:
    Pages –> All Pages , Quick Edit the page which you want to hide and select Draft in Status

    Thanks Prasanna. I’ve tried that a number of times, & it doesn’t work. The pages are still there even though the menu shows they are in Draft mode. It seems like no matter what I try, I can’t get the pages to disappear.

    Prasanna SP

    #33795

    Drafts shows up for logged in authors. Try logging out and see if you can still view that page.

    trailsnet

    #33796
    Quote:
    Drafts shows up for logged in authors. Try logging out and see if you can still view that page.

    Thanks again, Prasanna, but the pages still show up, even after I log out. I’m really puzzled as to why it is so difficult/impossible for me to remove pages from my website. I have a feeling there’s a simple answer to this problem, but I can’t think of what it is.

    Prasanna SP

    #33797

    Trash that page and check if it still shows up. You can restore that page later.

    trailsnet

    #33798

    Hi Prasanna,

    So I went ahead and trashed one of the pages that I don’t want to show up on my website anymore.

    The bad news: That page still shows up on the menu; my main goal is to get these pages off of the header & submenus on the website.

    The other news: When I click on the menu link for the page, I get an Error 404 message. So I still haven’t been able to accomplish my main goal of getting rid of the page links on the menu bar and drop-down menus.

    BTW – The website in question is Trailsnet.com and the pages I’m trying to get rid of are the Trailsnet Reviews & Trail Tours and all of the pages on the pull-down menu below them.

    Thanks for your help & patience.

    Prasanna SP

    #33799

    Eh?

    It seems you are using custom menus. Why can’t you just remove it from Header Menu? Go to Appearance –> Menus and select your Header Menu and remove those unwanted links from menu.

    puffin

    #33800

    Set up a new page called Archive (or similar). Make sure the new page doesn’t appear in the Menu.

    Make your page a child of Archive.

    ronangelo

    #33801
    Quote:
    I have tried the following:

    1.) going to the main menu in the menu page and clicking on the Remove button for each page, then hitting the Save Menu button. I have tried this numerous times and it just takes me to a blank page with no error message. Then when I go back to the site, the pages are still there.

    If you can’t remove a particular item try creating a new menu without the unwanted pages and use that instead.

    I wonder if a plugin is causing the blank page.

Viewing 15 posts - 1 through 15 (of 19 total)

You must be logged in to reply to this topic.