Redirected to homepage after clicking on menu items

  • aobuchowska

    #8024

    Hello,

    When I click on the menu items, about 50% of the time I get redirected to the homepage. For a split second the selected page appears in the menu but then the page gets redirected to homepage. I have tried inactivating the W3 Total Cache plugin but the problem persists. Could you please tell me what I can do to fix this problem. I would greatly appreciate it.

    Admin

    Syahir Hakim

    #40112

    Are you using the “Plugins Control” option in GM Neo Options > Advanced > Plugins Control?

    aobuchowska

    #40113

    Yes, I have a few plugins enabled or disabled.

    Admin

    Syahir Hakim

    #40114

    Can you list the plugins here?

    aobuchowska

    #40115

    Sorry about that.

    I enabled the following plugins:

    1. vslider

    I disabled the following plugins:

    1. Easy columns

    2. Line break shortcode

    3. Remove toolbar

    4. slidedeck2 personal

    5. wp show ids

    6. yet another random quote

    danbailan

    #40116

    This is quite interesting as it is a problem I am also encountering.

    I have moved from smart to smart pro to wordpress mobile and back again to see whether the problem exists in the switcher.

    I am using the plugins control in neo options

    Following enabled:

    Bulletproof security

    Contact Form 7

    Custom sidebars

    Dynamic widgets

    maxbuttons

    mobile smart

    nextgen gallery 2.0

    SEO ultimate

    Wp Supercache

    wp wunderground

    Following disabled

    backwpup

    currency converter

    google xml sitemaps

    insert php

    jjnextgen jquery slider

    executable php widget

    ultimate coming soon page

    I am creating the mobile site at the moment so updating pages frequently, using the switcher to test and so forth, disabling the switcher overnight so the site is accessible to mobile users as desktop.

    I gave up completely with the switch to desktop function as this simple corrupted my homepage.

    Admin

    Syahir Hakim

    #40117

    Try replacing line 203 of the theme’s `includes/theme-setup.php’ from this line:

    $current_url = add_query_arg( $wp->query_string, '', home_url( $wp->request ) );

    to this line:

    $current_url = home_url( add_query_arg( array(), $wp->request ) );

    Let me know if that helps.

    danbailan

    #40118

    Many thanks for your prompt reply to this issue.

    It’s the lines at the end of the of the file? As for me, this was at line 405 when opened in notepad, not 203.

    Presuming the above is correct, I have put that into practice and will report back.

    Thanks again

    danbailan

    #40119

    Sorry, it comes back with the following error:-

    Parse error: syntax error, unexpected T_VARIABLE in …./wp-content/themes/graphene-mobile-neo/includes/theme-setup.php on line 1

    Corrected on replacing the original theme-set-up file.

    Thanks.

    Admin

    Syahir Hakim

    #40120
    Quote:
    It’s the lines at the end of the of the file? As for me, this was at line 405 when opened in notepad, not 203.

    There is only a total of 207 lines in the includes/theme-setup.php file. Line count does not include text that is wrapped. It would be difficult to tell the line numbers if your text editor doesn’t display them, and Notepad doesn’t.

    It is at the end of the file though, in a block of code like this:

    if ( $reload_wp ) {
    global $wp;
    $current_url = home_url( add_query_arg( array(), $wp->request ) );
    wp_redirect( $current_url );
    exit();
    }
Viewing 10 posts - 1 through 10 (of 15 total)

You must be logged in to reply to this topic.