Put slider on a specific page

  • 007me

    #8887

    Hi,

    I want to place my slider in the blog page which is not in the front page but on another page here:

    http://ramon253.udiburg.com/%D7%91%D7%9C%D7%95%D7%92/

    I tried adding this code with the page ID of the blog which I took from the status bar when I opened it for editing:

    function graphene_display_slider(){
    if (is_page(466)){
    graphene_slider();
    add_action('wp_footer', 'graphene_scrollable');
    }
    }
    function custom_enqueue_scripts(){
    if ( ! is_admin() ) { // Front-end only
    wp_enqueue_script( 'graphene-jquery-tools' ); // jQuery Tools, required for slider
    }
    }
    add_action( 'wp_enqueue_scripts', 'custom_enqueue_scripts' );

    What am I missing?

    007me

    #41730

    Hi,

    Any response?

    Mod

    Kenneth John Odle

    #41731

    That’s because that page isn’t showing up with an id of 466.

    This is what your body tag looks like:

    <body class="rtl blog custom-background two_col_left two-columns">

    but it should look something like this:

    <body class="page page-id-27 page-template-default custom-background two_col_left two-columns">

    I’m not sure what your body tag is being rewritten. Maybe a plugin?

    007me

    #41732

    I can’t tell, how can I check it?

    And where did you see it exactly?

    Isn’t there a way to find the page ID?

    When I edit it is says it’s 465

    This is the link to it in the control panel:

    http://ramon253.udiburg.com/wp-admin/post.php?post=465&action=edit

    Mod

    Kenneth John Odle

    #41733

    I just used my browser’s “View Source” function and then searched for <body

    007me

    #41734

    So what do you suggest Kenneth?

    Mod

    Kenneth John Odle

    #41735

    Try disabling plugins to see if one of them is causing the issue.

    You are using the All in one SEO pack, which some users of WordPress have found troublesome. I might start with that one, or at least take a close look at its settings.

    007me

    #41736

    Will do, thanks, I’ll update

    007me

    #41737

    Turned off all plugins but it’s still the same:

    <body class="rtl blog custom-background two_col_left two-columns">

    Don’t think this is the case

    007me

    #41738

    Anyone? Anything?

Viewing 10 posts - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.