Return to Support

Put a space betwen buttons

Home Forums Graphene WordPress theme Support Put a space betwen buttons

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #9596

    Hi, i need to put a space between read more button (black) and facebook like button.

    And i like to pass the share buttons, in the posts pages, below the like button, just like in home page, not where it is.

    Any help?

    I use the facebook plugin to use the like button.

    nadainteressante.blog.br

    THX

    #44083
    Anonymous
    Member

    There are 2 possibilities.

    You put a buttom margin on the “Read more” button:

    .block-button, .block-button:visited, .Button, .button, .wpsc_buy_button {
    margin-bottom: 10px;
    }


    Or you put a top margin on the Facebook “Like” button:

    .pluginButton {
    margin-top: 10px;
    }

    If you put the top margin on the Facebook “Like” button you also have to put the top margin on the counter:

    .pluginCountButton {
    margin-top: 10px;
    }


    1QAODY3.png

    #44084

    Wow! Thanks! that works.

    Now just last the other one! I can´t find how it works.

    I use the addtoany plugin.

    THX a lot!

    #44085
    Anonymous
    Member

    Do you mean putting space between the share buttons?

    .addtoany_list.a2a_kit_size_32 a {
    margin: 0px 20px 0px 20px;
    }

    http://i.imgur.com/sTYgVSY.png

    #44086
    #44087

    Noooo 🙂 In the posts pages AddToAny (share buttons) is below the “related pages” (jp-relatedposts) and I’d like it to stay as the home page. The share buttons below the facebook like button and above the jp-relatedposts.

    I managed to do through the ” inspect element” in chrome but I don´t know how to do in the script.

    Like this:

    http://i.imgur.com/FzL9mMy.png

    #44088
    Anonymous
    Member

    Ok, you want to display the share buttons above the related posts.

    I believe you have to move the code for the share buttons above the code for related posts. This is in loop-single.php file of the graphene theme. Can you put the code of this file in here http://pastebin.com/ and post the link so I can have a look at what code you have to move?!

    #44089
    #44090
    Anonymous
    Member

    https://wordpress.org/support/topic/plugin-addtoany-sharebookmarkemail-button-move-button-to-top-of-postspages

    Disable automatic button placement in Settings > Share/Save Buttons > Placement

    Add the following code to your loop-single.php in your child theme folder. Backup the file before adding anything in case you mess something up.

    /* Display the AddToAny Share Buttons */
    <?php if ( function_exists( 'ADDTOANY_SHARE_SAVE_KIT' ) ) { ADDTOANY_SHARE_SAVE_KIT(); } ?>

    Try to add it AFTER the following code:

    <iframe style="border:none; overflow:hidden; margin-top:10px; width:620px; height:350px;" frameborder="0" scrolling="no" src="http://ocioso.com.br/troca-de-links/tag/id/dBr_CJlbZCd0vKSHGNfE7GYl8CfDBexs2GbknO5J6Gmm8ididJwL311Ohg8DY6W6Wuj_0-zHEP_jABcG9zRNzdm13z9d_6pH8ikeYPMeIc80siTSNGwq8MoIX4bRFlRLZOknhPN-KlzvijG3yfZHCdbaeuaaMOU0JwBvKuOyXW5hPvEL39LbHcwo__d7lw7s9z-rOqPTrgOUaIvR2hZHnxG7c7y_BGa7XucCVgIcdYi36cqSgvCUkacTFbbiduvA|f5a0L81fknbdTBtB37dENquJupWVZmvvZifGmSDUL_w="></iframe>

    </div>

    Then check if that’s the right position. If not, you gotta place the first code on another position.

    #44091

    Maaan, didn´t work for me! when I disable the automatic way the share buttons stop to appear in the home page and the buttons appear on the top or on the bottom of posts, never where i liked it to be 🙁 buuuut i found this: http://winningwp.com/how-to-reposition-jetpacks-related-posts-module-and-other-customizations/

    A way to bring related posts to the bottom of the page.

    using this code in functions.php:

    function jetpackme_remove_rp() {
    $jprp = Jetpack_RelatedPosts::init();
    $callback = array( $jprp, 'filter_add_target_to_dom' );
    remove_filter( 'the_content', $callback, 40 );
    }
    add_filter( 'wp', 'jetpackme_remove_rp', 20 );

    and this where you told me to do ( loop-single.php):

    <?php echo do_shortcode( '[jetpack-related-posts]' ); ?>

    That works for me!

    Thanks a lot for your support! i realy apreciate that!

    Merry christmas and a happy new year!

    #44092
    Anonymous
    Member

    I wanted to post this one first but I thought it will be too difficult for you so I looked for a solution to just replace the share buttons instead of the related posts. 😀

    Anyways, I’m glad you fixed it.

Viewing 11 posts - 1 through 11 (of 11 total)

You must be logged in to reply to this topic.