Problems with WWW resolve

  • Anonymous

    #2064

    Hi all,

    Firstly – I love the theme, it’s great, and I will definitely be donating once my website is finally done and online! I am having great trouble with my website at http://www.joshphillips.co.uk. The problem I have is that http://www.joshphillips.co.uk works, and http://joshphillips.co.uk isn’t loading the theme properly. The full code for my index.php file is as follows:

    <HEAD>

    <META NAME=”DESCRIPTION” CONTENT=”Official website of business graduate Josh Phillips, interested in music, gaming, marketing, social networking and international business”>

    <META NAME=”KEYWORDS” CONTENT=”Graduate, available, career, job, business, Leicester, UK, Stoney Stanton, Leicestershire, Music, Videogames, Travelling, Fun, Social networking, Twitter, Faceboook”>

    </HEAD>

    <?php

    /**

    * Front to the WordPress application. This file doesn’t do anything, but loads

    * wp-blog-header.php which does and tells WordPress to load the theme.

    *

    * @package WordPress

    */

    /**

    * Tells WordPress to load the WordPress theme and output it.

    *

    * @var bool

    */

    define(‘WP_USE_THEMES’, true);

    /** Loads the WordPress Environment and Template */

    require(‘./wp-blog-header.php’);

    ?>

    However when I visit http://joshphillips.co.uk, the page source is only for the <HEAD> tags. In wordpress settings, if I alter my site’s URL from being http://www.joshphillips.co.uk to http://joshphillips.co.uk, it will work at http://joshphillips.co.uk, but it will no longer work for http://www.joshphillips.co.uk! So it seems I can have one or the other, but not both! I have spoken to my hosting company and they assure me that my DNS settings at .htaccess are configured correctly so it must be something to do with wordpress – I have tried disabling all plugins but it still wouldn’t work. Am I missing something very simple here? Any help would be much appreciated! Thanks!!

    Admin

    Syahir Hakim

    #18460

    At the top of your page source there is this chunk of code:

    <HEAD>
    <META NAME="DESCRIPTION" CONTENT="Official website of business graduate Josh Phillips, interested in music, gaming, marketing, social networking and international business">
    <META NAME="KEYWORDS" CONTENT="Graduate, available, career, job, business, Leicester, UK, Stoney Stanton, Leicestershire, Music, Videogames, Travelling, Fun, Social networking, Twitter, Faceboook">
    </HEAD>

    Those really shouldn’t be there, even before <html> tag is opened. Know what might be inserting that code there?

    You might also want to try and resave your permalink settings at WP Admin > Settings > Permalinks.

    Anonymous

    #18461

    Thanks for your reply. I tried removing the code in the <HEAD> tags – Also tried putting <HTML></HTML> tags around the entire thing – neither worked. I just changed my permalink settings in WP and saved them – but still no joy! Any other ideas?

    Josh

    Anonymous

    #18462

    Hi Joshua,

    What plugins are you using? This looks like it might be an SEO plugin causing a conflit.

    Anonymous

    #18463

    Hi Josh, thanks for the reply – I have already tried disabling every plugin but still get the same problem. The only plugins I use slightly related to SEO are the google xml sitemaps and strictly autotags…

    cheers,

    josh

    Anonymous

    #18464

    And you tried disabling the “strictly autotags”?

    Are you using any page caching plugin?

    Anonymous

    #18465

    Hi,

    I have disabled strictly autotags, but I still have the same problem. As far as I know I’m not using any page caching plugins.

    Thanks,

    Josh

    Admin

    Syahir Hakim

    #18466

    Seems like it’s working fine for both with and without the www now?

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.

Do NOT follow this link or you will be banned from the site!