Problem with W3 Cache

  • Chris

    #7192

    This isn’t really a bug in Neo, and I don’t thiink it’s a bug in mobile switcher either, but Mobile switcher doesn’t work when I have W3 Cache enabled in any kind of way. If I do get it to work, then as soon as I do an update to, or add a new post…all goes out the window again.

    I’ve been having a problem with w3 anyway when it comes to minifying like it’s supposed to, unless I set minify to “automatic” on the General Settings Page of the W3 Cache plug-in, but even when things minify correctly, if I make one single change, then the mobile switcher will not work.

    Here’s what I’m hoping 🙂

    I’ve looked for about an hour and a half and in order to make sure nothing in my .htaccess file isn’t messed up, but all I really need to know is if what I have in it already is correct, and since it will take Syahir about thirty seconds to tell me if it’s right, I figure I might as well just ask (but I am trying to learn a little bit about Apache and how .htaccess rules work. Here’s what I have in it now.

    RewriteOptions inherit

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress
    AuthName "Main Directory"
    AuthUserFile "/home/lancekid/.htpasswds/public_html/passwd"

    <Files 403.shtml>
    order allow,deny
    allow from all
    </Files>

    If someone could tell me if this is correct, then I will at least know that I can maybe try another caching plugin (because I really do not need one as fancy and powerful as W3 just to cache pages (really don’t care about minifying right yet), or start disabling a couple of plug-ins and seeing where the conflict is (because it started way before I ever tried the first graphene mobile theme, so it’s not graphene).

    Thanks for any help or suggestions.

    Admin

    Syahir Hakim

    #37345

    Have you enabled the “User Agent Groups” option in W3TC? You need the enable both the “High” and “Low” group, and set the theme to “– Pass-through –“.

    bwrHBCS.png

    Chris

    #37346

    Wow. See, that’s why I broke down and asked you, lol. Thank you again for your patience and help. That fixed the problem and saved me a whole lot of time.

    Thank You!

    Admin

    Syahir Hakim

    #37347

    You’re welcome! Marking thread as resolved then. You can do this yourself as well.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.

Do NOT follow this link or you will be banned from the site!