Problem with a conclusion of comments to record

  • steken

    #3357

    Hello!

    After installation of last version of a theme 1.6, there was a problem with a conclusion of quantity of comments to record. On the main page where it is deduced records the quantity of comments is displayed, should be so: “3 comments”, and at me it is deduced: “d% comments”. That is instead of number it is shown “d%”, prompt as to correct!?

    Yours faithfully Serhio!

    Anonymous

    #24470

    Are you using default English or any other language? Please give your site address.

    Moved to support.

    steken

    #24471

    I use Russian! I from Russia.

    The blog address: http://it-blogs.webuda.com/

    Has checked up, when one comment in record that is deduced “%d the comment”, (that is instead of 1 it is shown %d) and when 2 and more comments in article like normally shows, checked with 5 comments. The blog only has opened!

    Anonymous

    #24472

    Okay, that might be a typing mistake because d and s are close to each other in the keyboard. To fix this, open your language .po file (ru_RU.po) and replace %d комментарий with %s комментарий. Save and re-upload the ru_RU.po and ru_RU.mo files to /graphene/languages directory

    You may need to read this – Translating the theme

    Or simply notify the translator about this issue.

    steken

    #24473

    Has made, but the result hasn’t changed! Has edited as you have told, and has filled in back in a root. As well shows why that “%d” and when only 1 comment in record! That can in what the friend business?

    Admin

    Syahir Hakim

    #24474

    Seems like it’s displaying fine now?

    r8eesw.png

    steken

    #24475

    Syahir Hakim it when 2 and more comments! That is when 1 comment in record that is deduced “%d” and when 2 and more comments that all is good. Now come on a blog and look, I have removed 1 comment.

    Admin

    Syahir Hakim

    #24476

    steken

    #24477

    Has made, all has turned out! I have understood in what there was a problem.

    msgid “1 comment”

    msgid_plural “%d comments”

    msgstr [0] “1 comment”

    msgstr [1] “%d the comment”

    msgstr [2] “%d comments”

    Here in this line msgstr [0] “1 comment” it was necessary to put figure 1, instead of “%d”. That is this parameter generates quantity of comments but when the comment 1, sense to generate isn’t present. Here it also returned this value.

    Thanks big for the help!!!

    Anonymous

    #24478

    Well..

    Marking as resolved.

Viewing 10 posts - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.

Do NOT follow this link or you will be banned from the site!