Problem to change a link in the footer

  • Anonymous



    Excuse my English, I’m French and I use Google translator.

    So,I’m using Graphene and I created a child theme. I managed to change the appearance of copyright in footer.php file.

    I would also change the back to top link and put an image in place of the link – text.

    In the footer.php file, I removed this code: `<?php if ( ! $graphene_settings ) : ?>

    <li class=”menu-item return-top”><a href=”#”><?php _e(‘Return to top’, ‘graphene’); ?></a></li>

    <?php endif; ?>`

    In place, I put the following code:

    <?php if ( ! $graphene_settings['hide_return_top'] ) : ?>
    <li class="menu-item return-top"><a href="#"><img src="wp-content/uploads/2013/05/fleche-haut-3.jpg" alt="Retour vers le haut" title="Remonter en haut de page" /></a></li>
    <?php endif; ?>

    It works on static home page and on page 404 … but not on the other pages!

    You can see my site: my website about Burgundy (France)

    On pages where my code doesn’t work, there is the call to the function do_action (‘graphene_loop_loop_footer’) but I don’t know how to get or how to change this.

    An idea to help me easily?




    I raise the topic

    I ‘d like to change the link “return to top” in footer by adding an image. My code does not work on every page.

    I need to understand where is the call to the function do_action (‘graphene_loop_loop_footer’)

    Help me,please!



    Just throw this to Custom Head Tags in Graphene Options –> Advanced. No need to edit any theme file.

    <script type="text/javascript">
    $('.return-top a').html('<img src="" alt="Return to top" />');

    Restore the theme files if you’ve edited any.



    Hello Prasanna,

    Thank you for your help.

    Meanwhile, I got an answer here:

    It was enough to add a slash in the path to my image!

    So I keep my code in the footer.php since now it works. (don’t worry, it is a theme-child)

    Thank you anyway.

Viewing 4 posts - 1 through 4 (of 4 total)

  • You must be logged in to reply to this topic.