Posts not showing on blog page

  • JJH

    #5371

    I am new to your template. Sorry for the simple question. I went to reading and set the front page as static. for posts I created a ‘blog’ page and picked that for posts. I have written three posts and none of them show up on this page. What am I missing?

    thanx you

    Josh

    #31763

    Hi jjh, and welcome to the forum!

    Give this page a quick read… and let me know if it doesn’t help you.

    http://codex.wordpress.org/Creating_a_Static_Front_Page

    JJH

    #31764

    Hi Josh: appeciate the directions but it doesn’t help me. I did all the page suggested. My home page I setup as static and named it. Then I created another page called blog and saved it and put it next to Posts Page. But my posts will not show up on that page. It probably has to do with the permalinks that direct the posts to the blog page????? The posts show up in the slider as directed and also on the blog posting on the sidebar of the front page, but alas, no blogs on the blog page I set up. Have any other suggestions. Thank you so much for your help.

    Josh

    #31765

    Hmmm… have you done anything with your .htaccess file?

    Perhaps try to change your permalinks to something different… click save… switch them back… and save again.

    JJH

    #31766

    By the way, when I click on ‘blog’ it says

    Index of /blog

    Parent Directory

    wp-content/

    Apache Server at http://www.xxxxxxxx.com Port 80

    All righty, I go to settings, and then permalinks. Another ‘don’t know what I am doing’ question. How do I change a permalink on that page? I printed out Codex Using Permalinks from wordpress and well, that was confusing.

    thanx for your help.

    Josh

    #31767

    Just “tick” one of the other options and save… like “date and title”… although I’m not sure if that’s actually an option 🙂

    And then click it back to what you had and save again.

    JJH

    #31768

    I hate to say it but nothing changed. Ya know, I clicked on a post that was in the slider and it took me to the ‘Blog’ page where the post recides. But if I click on Blob page first, it won’t go there, it just gives me what I wrote above. I am a little frustrated and don’t know what to do. I can start over by reloading your template (of course I would copy what I wanted to save) and see what happens. Should I try that?

    Mod

    Kenneth John Odle

    #31769

    I see your main page here: http://www.judyhaar.com/

    and your blog page here: http://www.judyhaar.com/myblog/

    Did you get this sorted or am I missing something?

    Admin

    Syahir Hakim

    #31770

    Your posts are showing fine here:

    http://www.judyhaar.com/myblog/

    JJH

    #31771

    I fixed it by reloading the template and changing the name of ‘blog’ to MyBlog (don’t know or care why it works with a different name, just that it works ;0). Also, when I reloaded, it put the page ‘home’ back in. I can live with that. I just need to reformat around the home page. I really appreicate your support. You guys have been great and I want to thank Josh and you both for helping. Thank you again.

    Josh

    #31772

    Thank you, JJH.

    Are you using a custom menu? If you are, you can change that name from MyBlog.

    The “Home” page is going to stay there.. because you have to have a home page. Otherwise… where would your site “land”?? However, using a custom menu… you can change the name of that as well.

    JJH

    #31773

    Hi Josh:

    I originally changed the name of ‘home’ to something else as my landing page but, to tell the truth, I have spent so many hours on the ‘blog’ problem that I have turned off to the name so I will stay with ‘myblog’ and home. I am now going to find a widget that allows me to collect an email for a free ebook, a call to action. Having fun. And thank you again for all your help.

    Josh

    #31774

    lol.. understood 🙂

Viewing 13 posts - 1 through 13 (of 13 total)

You must be logged in to reply to this topic.