posts not showing correctly on homepage

  • clbrown1

    #5295

    I am using the frontpage sidebar widgets which allow alternate widgets on the homepage and they appears to be working correctly, however posts are side by side and are excerpts rather than running the full width and showing the full post.

    What am I missing in my settings?

    The website is http://blogs.henrico.k12.va.us/studentzone/

    Josh

    #31492

    You have your theme set up to display “homepage panes”. Is this your intended display?

    clbrown1

    #31493

    When I disable home page panes, the posts don’t show up at all.

    Josh

    #31494

    If you have homepage panes enabled… it means you are using a “static” homepage.

    If you want your blogroll to appear on your homepage, you’ll need to set your homepage to “show latest posts”.

    http://www.simplethemes.com/tutorials/help/home-page-setup

    clbrown1

    #31495

    I chose to use a static page for the homepage so I could get the alternate widgets to work with a column on either side of the posts. Under graphene theme options – Homepage Panes – I selected Latest posts for Type of content to show.

    Under Settings – Reading – for front page displays, I selected A static page and for the front page option I selected the three column page I created to be the homepage. I’ve left the Posts page option blank.

    I can’t find any reason why the posts are showing up side by side and as excerpts

    clbrown1

    #31496

    okay, I just created a page called blog and in the reading settings assigned it to Posts page and I still get the same thing.

    Josh

    #31497

    Okay.. so you want a homepage with two columns… and one main content area where you posts are displayed… one underneath the other?

    For this, you will need to change your “reading” settings from “static” to “show latest posts”.

    Now, you will need two “pages”. One [preferably] titled “Home” and one [preferably] titled “Blog”.

    Don’t add any content to these two pages. Just name them, and save them.

    Now, back in your “reading” settings… set to “display latest posts” and use the “Home” page for the homepage.. and the “Blog” page for your posts.

    This link might help??

    http://codex.wordpress.org/Settings_Reading_Screen

    clbrown1

    #31498

    What I really want is a 3 column front page with posts displayed in the main content area, one underneath the other. Just like example on this page:

    https://forum.graphene-theme.com/features-and-functionalities/widget-areas/

    I originally had my reading settings to “show latest posts” but the alternate widgets for the homepage wouldn’t display unless I made the frontpage a static page. Everything appears to work correctly when it’s set this way except how the posts show which seems to me to be unrelated. Something, somewhere is telling it to put excerpts instead of full posts.

    In the reading section you cannot specify frontpage and posts page if you set the first radio button to “show latest posts”; these options go with static pages.

    It would appear that if I want my posts to show up in full, one underneath another on the front page, that I cannot have the alternate widgets in use. The only other alternative would be to have all pages three columns which I don’t want.

    I want it to look like the page in the link above…

    I also just tried making the front page three columns and making the blog page two columns but it still shows three columns on the blog page. Why would this be? I thought you could override the theme default. My other pages show up two columns but not the blog page or a category display (not an actual page). It seems that anyplace the blogroll shows up, the theme default for columns is used even if it’s a page where I’ve overridden that default.

    I’m getting so frustrated but really appreciate your help…

    Josh

    #31499

    Okay… slow down 🙂

    Let’s tackle this one step at a time.

    Go to Graphene Options -> “display” tab -> Excerpts display options

    Is the “Show Excerpts in front page” checked?

    clbrown1

    #31500

    no it’s not.

    clbrown1

    #31501

    sorry I am bouncing around so much but I am trying different options to see what they do. Somehow I now have the posts showing on the front page the way I want them – full posts and one underneath another. What causes posts to be side by side and excerpted is making the front page static.

    my only problem at this point is that any page that shows the blogroll is three columns but I may have to be content with that.

    Josh

    #31502

    You’re fine 🙂

    I had to run out for a minute. Lemme re-group and I’ll be back with ya.

Viewing 12 posts - 1 through 12 (of 12 total)

You must be logged in to reply to this topic.