Posts and Pages not showing anywhere

  • meryl

    #1506

    I’ve set the home page to show posts from the NEWS category. And I have content on the pages. But no content is showing up at all in the new theme. I don’t see this problem reported, so I must be doing something stupid 🙂

    http://merylsentme.meryl.net/

    Admin

    Syahir Hakim

    #16016

    Something caused the page to stop loading just before the content area. Did you modify the codes? Or via child theme? Or maybe some plugin is causing the errors? It’s difficult for me to troubleshoot it since I don’t have access to the site’s logs and PHP on your site is configured to not display error messages.

    meryl

    #16017

    I didn’t touch any of the page templates. I even deactived the child and it still didn’t work. I found the error:

    [Sat Aug 06 06:08:43 2011] [error] PHP Fatal error: Call to undefined function get_post_format() in /merylsentme/wp-content/themes/graphene/loop.php on line 10

    That’s the same error I mentioned in a different forum post.

    meryl

    #16018

    I gave up. Blew away the site. Installed fresh WP and Graphene. Problem solved. Both of these incidences were based on existing sites using an old version of Graphene and upgrading the Graphene. Maybe it was something from the old version that caused problems with loop.php? It was v1.1.2.

    Admin

    Syahir Hakim

    #16019
    PHP Fatal error: Call to undefined function get_post_format()

    This error is more likely due to using an older version of WordPress, prior to version 3.1 when the Post Format function was added.

    meryl

    #16020

    Syahir, you’re right. I just upgraded the website to 3.1 (I use Fantastico since future webmasters won’t know how to upgrade and automatic doesn’t always work). But rather than upgrading the theme, I deleted the v1.1.2 theme and uploaded the 1.4.1 theme. No errors.

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.

Do NOT follow this link or you will be banned from the site!