Return to Support

Post title doesn't show up in front page

Home Forums Graphene WordPress theme Support Post title doesn't show up in front page

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #9598
    markyvg
    Member

    Hi! I’ve looked in the forum but I can’t find a similar problem.

    I’ve set a static page in my blog, and configured the panes to show the latests posts below. All is fine, except that the post titles don’t appear, only the image and text. You can see the problem here http://www.fitnessrevolucionario.com/ . If I check the sample in the documentation (http://docs.graphene-theme.com/Homepage_panes) I can see the titles of the posts, so there must be some error in my case.

    Thanks a lot for your help!

    Marcos

    #44093

    Because you have edited the theme stylesheet to include this code:

    .page-id-6794 .post-title, .page-title {
    display: none;
    }

    Since your front page is id#6794, you are telling a web browser not to display any page titles on that page.

    Also, you have edited theme files. You should never edit theme files. This is always a bad idea because it will always lead to problems down the road.

    Try adding this code to Graphene’s custom CSS option or to your child theme’s stylesheet:

    .homepage_pane .post-title {display: block;}

    #44094
    markyvg
    Member

    Thanks a lot for your help Kenneth! If I remove that code the post title shows correctly, but then the title of the main page also appears and I don’t want that. Adding .homepage_pane .post-title {display: block;} doesn’t seem to do anything, all the titles appear with or without that code. Do you think it is possible to hide the main page title but not the post titles?

    I really appreciate your help.

    Thanks!

    #44095
    Quote:
    . Do you think it is possible to hide the main page title but not the post titles?

    That’s what I was trying to do with the above code but it didn’t work (hide all and then display some is bad form, actually), so let’s try a different, hopefully better way:

    `.page-id-6794 h1.post-title {

    display: none;

    }

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.