Post shows up on static front page

  • AnneL


    I am using the newest WordPress and the newest Graphene. If I create any post, it shows up on the home page even though I have selected a static front page and disabled homepage panes. I have also tried adding the following code to the Custom CSS page to no avail.

    .home .post {

    display: none;


    How can I fix this?



    I am having a similar issue. I have just installed WP 5.2.3 with the latest Graphene theme and when I set a static page as my home page, the top part is till the first post with the static page displayed underneath it.

    Any clues?


    Syahir Hakim


    Hi AnneL and TerryJ,

    Please provide the URL of the websites where this is happening so that we can take a look. Thanks!



    Sorry, should have thought of that –
    Mine is



    Syahir Hakim


    Thanks for that. So far I’m not able to reproduce the issue on our development site. Please confirm that you have disabled the Home Page Panes feature in Customize > Graphene: General > Home Page Panes.

    If that is already disabled, can I have temporary WP Admin access to your site to investigate the issue further? You can use the form on this page to securely send the details:



    Hi Syahir,

    The ‘Home Page Panes’ option wasn’t disabled so I disabled it and it still displayed the first post. I then found if I disabled the slider the post disappeared and it is working as I want it to now so thanks for your help.


    Syahir Hakim


    Ah yes, that’s right. The post before the static page is the slider. The posts after the static page is the Home Page Panes. You’ll need to disable both if you want only the static page to appear and no other posts.

Viewing 7 posts - 1 through 7 (of 7 total)

  • You must be logged in to reply to this topic.