Return to Bug report

Post excerpts (and some widgets) get repeated with 1.5.5 update.

Home Forums Graphene WordPress theme Bug report Post excerpts (and some widgets) get repeated with 1.5.5 update.

Viewing 15 posts - 1 through 15 (of 16 total)
  • Author
    Posts
  • #2372
    stephenwiggs
    Member

    Sites using post excerpts on homepage panes are having all the post excerpts, plus any plugins that appear after them, repeated. This has been noted in several blogs using excerpts here:

    https://forum.graphene-theme.com/graphene-support/graphene-is-showing-all-posts-in-homepage-pane

    I have also noticed it duplicating action hook widgets on a post.

    The only thing I have seen changed in the changelog is a change to the copyright text and fixing an XSS vulnerability. It is probably related to the latter.

    This has also been reported in the WordPress Graphene forum; I have let users there know to follow this thread.

    #19980

    Apparently, this is also showing up on the mobile version:

    https://forum.graphene-theme.com/graphene-mobile-support-requests/problemas-con-el-homepage_panes-en-la-pagina-de-bienvenida

    (Google Translate says: “Hi, I have problems with the issue in this part, it’s like the same section is repeated twice …

    thanks for the help!”)

    #19981
    Syahir Hakim
    Keymaster

    I’m investigating this. Thanks.

    #19982
    Syahir Hakim
    Keymaster

    OK, open up the footer.php file and delete this line near the top:

    <?php do_action( 'graphene_bottom_content' ); ?>

    That action hook has already been defined in the loop.php, and it was repeated in the footer.php, hence the repeating of whatever functions being attached to that action hook.

    Let me know if you can confirm the fix and I’ll push an update to the WP.org theme repository.

    #19983

    kissesssss, Syahir. thank uuuuuuuuuuuuuuuuuuuuuuuuu. am sooo exciteddddddddddddddd. tnxx

    it worked. perfectly!

    #19985

    Yep, that fixed it. Thanks!

    #19986
    Prasanna SP
    Member

    Thanks Syahir! That fixed the issue.. 🙂

    #19987
    Gordias
    Member

    nice job, thx (from czech republic:)

    http://www.povidkypribehy.cz

    #19988
    dfoucart
    Member

    Thanks a lot… seems you saved my reputation (everything here was thinking I started sluttering…)

    #19989
    brunomania
    Member

    hola me sucede algo parecido… que es que un fragmento parece que se repite dos veces…

    <div class=”homepage_panes”>

    <div class=”homepage_pane clearfix”> <h3 class=”post-title”> Alumnos </ h3> <div class=”post-excerpt”> <p> Bienvenidos Alumnos del Departamento de Cs. Sociomédicas y Salud Pública </ p> </ div> <p class=”post-comments”> Continuar leyendo </ p> </ div> </ div>

    nose como hacer para que no se repita…

    solicito ayuda!!!

    gracias…

    #19990
    hkey
    Participant

    Hi, deleting the <?php do_action( ‘graphene_bottom_content’ ); ?> in the footer file did work. Thanks

    #19991
    rk
    Member

    worked like a charm. thanks, boss! 😀

    #19992
    Sas
    Member

    Yes! Worked perfetly!! TY so much! 😀

    #19993
    bagapreta
    Member

    Syahir, I just updated to version 1.5.5 from 1.4.1 and all my posts from homepage disapear and a weird picture is shown by slider.

    I opened up the footer.php file and deleted the line:

    <?php do_action( ‘graphene_bottom_content’ ); ?>

    But it didn’t work.

    There was nothing selected at the ‘Front page posts categories’ option anymore. I selected ‘–Disabled–‘ again and after saving my content was back!

    But the weird pitcure at slide still remains. So I disabled the SmartYouTube plugin and now everything is ok.

    Take a look:

    http://bagapreta.com.br

    All the best.

    #19994
    carolacat
    Member

    thank you, that worked a treat!

Viewing 15 posts - 1 through 15 (of 16 total)

You must be logged in to reply to this topic.