Plugin activation causes strange errors on page notice

  • BonnieC

    #3888

    HI,

    I’ve added a few plugins to a brand new site and each time I do I encounter this notice at the top of the dashboard:

    Notice: has_cap was called with an argument that is deprecated since version 2.0! Usage of user levels by plugins and themes is deprecated. Use roles and capabilities instead. in /usr/www/users/greatwf/hermanus/wp-includes/functions.php on line 3551 Notice: has_cap was called with an argument that is deprecated since version 2.0! Usage of user levels by plugins and themes is deprecated. Use roles and capabilities instead. in /usr/www/users/greatwf/hermanus/wp-includes/functions.php on line 3551 Notice: has_cap was called with an argument that is deprecated since version 2.0! Usage of user levels by plugins and themes is deprecated. Use roles and capabilities instead. in /usr/www/users/greatwf/hermanus/wp-includes/functions.php on line 3551 Notice: has_cap was called with an argument that is deprecated since version 2.0! Usage of user levels by plugins and themes is deprecated. Use roles and capabilities instead. in /usr/www/users/greatwf/hermanus/wp-includes/functions.php on line 3551 Notice: has_cap was called with an argument that is deprecated since version 2.0! Usage of user levels by plugins and themes is deprecated. Use roles and capabilities instead. in /usr/www/users/greatwf/hermanus/wp-includes/functions.php on line 3551 Notice: has_cap was called with an argument that is deprecated since version 2.0! Usage of user levels by plugins and themes is deprecated. Use roles and capabilities instead. in /usr/www/users/greatwf/hermanus/wp-includes/functions.php on line 3551 Notice: has_cap was called with an argument that is deprecated since version 2.0! Usage of user levels by plugins and themes is deprecated. Use roles and capabilities instead. in /usr/www/users/greatwf/hermanus/wp-includes/functions.php on line 3551 Notice: has_cap was called with an argument that is deprecated since version 2.0! Usage of user levels by plugins and themes is deprecated. Use roles and capabilities instead. in /usr/www/users/greatwf/hermanus/wp-includes/functions.php on line 3551 Notice: has_cap was called with an argument that is deprecated since version 2.0! Usage of user levels by plugins and themes is deprecated. Use roles and capabilities instead. in /usr/www/users/greatwf/hermanus/wp-includes/functions.php on line 3551 Notice: has_cap was called with an argument that is deprecated since version 2.0! Usage of user levels by plugins and themes is deprecated. Use roles and capabilities instead. in /usr/www/users/greatwf/hermanus/wp-includes/functions.php on line 3551 Notice: has_cap was called with an argument that is deprecated since version 2.0! Usage of user levels by plugins and themes is deprecated. Use roles and capabilities instead. in /usr/www/users/greatwf/hermanus/wp-includes/functions.php on line 3551 Notice: has_cap was called with an argument that is deprecated since version 2.0! Usage of user levels by plugins and themes is deprecated. Use roles and capabilities instead. in /usr/www/users/greatwf/hermanus/wp-includes/functions.php on line 3551 Notice: has_cap was called with an argument that is deprecated since version 2.0! Usage of user levels by plugins and themes is deprecated. Use roles and capabilities instead. in /usr/www/users/greatwf/hermanus/wp-includes/functions.php on line 3551

    Also after I’d added a banner to the widget area I see this on the home page:

    Notice: Undefined index: post_type in /usr/www/users/greatwf/hermanus/wp-content/plugins/animated-banners/BannerAdmin.class.php on line 122

    All was fine until I added plugins. Please advise soonest.

    Also want to Thank You for assisting me very quickly with another site I had issues with. Truly appreciated the speedy response.

    Regards,

    Bonnie

    Mod

    Kenneth John Odle

    #26481

    has_cap was called with an argument that is deprecated since version 2.0! Usage of user levels by plugins and themes is deprecated. Use roles and capabilities instead.

    This sounds like you are using an ancient plugin, or at least an ancient version of a plugin. You don’t mention which plugin, so it’s impossible to say for sure. You’ll need to check the plugin’s page on the WP plugin repository to see when it was last updated or to make sure you are using the latest version.

    Your site link is returning a 404 error. Difficult to say more without seeing the site.

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.