PHP SPrintf Warning

  • Chronovore

    #5305

    I updated to 1.8 and began receiving a warning (Too few arguments) that displays on my page cocerning line 28 of theme-head.php.

    You can see this at http://bryanforester.com/wordpress at the top of the page.

    I was able to suppress the warning by prepending “@” to call_user_func_array() but wanted share.

    Mod

    Kenneth John Odle

    #31281

    Since you are now suppressing errors, please post the entire error message that you received here.

    Chronovore

    #31282

    Sure. I suppressed the error on my main blog (http://bryanforester.com) but on my testing blog (http://bryanforester.com/wordpress) The error still shows at the very top of the page. The error blends with the background, but the text is:

    Warning: sprintf() [function.sprintf]: Too few arguments in /home/content/97/9624797/html/wordpress/wp-content/themes/graphene/includes/theme-head.php on line 28

    SteviniP

    #31283

    Okay so this is not something I did to my blog…Yay! I suppose this bug will be fixed with a patch soon. Do I need to worry that my blog will not work properly?

    Mod

    Kenneth John Odle

    #31284

    @chronovore

    I didn’t realize that was your test blog since it looks just like your regular blog. My test blog looks like a mess.

    resourcefulblogger

    #31285

    I have the same error and wanted to know if I should do a site backup and restore? Or wait until a new update is available?

    sanuja.com

    #31286
    Quote:

    I didn’t realize that was your test blog since it looks just like your regular blog. My test blog looks like a mess.

    It is at the very top of his page; “Warning: sprintf() [function.sprintf]: Too few arguments in /home/content/97/9624797/html/wordpress/wp-content/themes/graphene/includes/theme-head.php on line 28”

    Jay

    #31287

    I’m getting the exact same error. Now, I just have to go to the wordpress website and do a search on how to suppress errors while the problem is being resolved 🙂

    Admin

    Syahir Hakim

    #31288

    Everyone, try replacing the content of includes/theme-head.php with the updated one here:

    http://graphene.googlecode.com/svn/trunk/graphene/includes/theme-head.php

    jonas klein

    #31289

    Hello syahir the code for me not to run the error still brace on line 28

    Jay

    #31290

    Syahir, unfortunately the problem is still there. The warning has not changed, it still says:

    Quote:
    Warning: sprintf() [function.sprintf]: Too few arguments in /home/content/w/e/b/webeida/html/wp-content/themes/graphene/includes/theme-head.php on line 28

    resourcefulblogger

    #31291

    Doesn’t help me. I have no idea how to do it. Working with server to do a back up and restore and they just screwed up everything. This day sucks!

    Admin

    Syahir Hakim

    #31292

    Have you noticed if there’s any colour on your site that’s changed since the update?

    Also, try resetting the theme’s options. You can export the settings first in case you want to import them back later.

    Jay

    #31293

    Yes, Syahir. Firstly, I loved your new feature to be able to change the colour of the menus so I spent time changing them. Also, while doing that, the colours I had for my widgets defaulted back to the default theme colours. I had to go back and change them all again. It was while I was editing the fonts that I got this error.

    Admin

    Syahir Hakim

    #31294
    Quote:
    It was while I was editing the fonts that I got this error.

    This is the information I need. Thanks, looking into it now.

Viewing 15 posts - 1 through 15 (of 37 total)

You must be logged in to reply to this topic.