''Older Posts'' link not working — redirects to homepage

  • ABasketballJones

    #3855

    Hi guys,

    Just discovered this today when i went searching for one of my posts on my blog page. I have a static page and blog page set up.

    http://abasketballjones.com/

    On the blog page http://abasketballjones.com/blog at the bottom when i click ”Older Posts” it showed the link of http://abasketballjones.com/blog/page/2/ but it actually redirects and shows the front page, but with the url of http://abasketballjones.com/page/2/ this time around

    Anyone got any idea what has happened? I haven’t fiddled with any settings lately that should cause that and i’m pretty certain it used to work.

    Thanks

    Prasanna SP

    #26271

    1. Check Permalink Settings.

    2. Temporarily Deactivate all plugins and check again.

    Prasanna SP

    #26272

    (Off the topic talk)

    Your site is badly suffering from pingback/trackback spam..

    ABasketballJones

    #26273

    My permalinks structure is custom and has always been: /%year%/nba/news/%postname%/

    Deactivated all plugins.

    Just discovered this plugin: WP No Category Base – WPML compatible

    Removes ‘/category’ from your category permalinks. WPML compatible.

    Can’t remember when the hell i installed that, but when i deactivate, the /blog page is a 404 error page…

    Also, when i upgraded to new WP the other day, it reset my comments settings and i got attacked by spam, but thanks.

    Prasanna SP

    #26274

    /%year%/nba/news/%postname%/ doesn’t seem to be a valid permalink structure. You have to use tags only.

    ABasketballJones

    #26275

    I changed the permalink to a pre-set one. Still same result. Before i some how managed to get to older posts, but the url was completely different.

    I’ve sent a question to wordpress people, hopefully they come up with something also.

    Thanks Prasanna

    Prasanna SP

    #26276

    Do you use any SEO plugin? A misconfiguration(?) of canonical URLs might be causing the issue.

    ABasketballJones

    #26277

    I have SEO Ultimate .. I deactivated that before, no change.

    Prasanna SP

    #26278

    Try deactivating all plugins once again and change permalink structure to Post name (/%postname%/). Then clear browser cache.

    ABasketballJones

    #26279

    Can you try it now please. On my mozilla browser, it seems to be ok, on IE it doesn’t..

Viewing 10 posts - 1 through 10 (of 13 total)

You must be logged in to reply to this topic.